UPDATED kernel fails to launch

I updated my Fedora 32 to latest kernel and now I am getting errors resulting in a failure to launch.

I launched back into a working kernel and tried to regenerate my intramfs and just a HOST of errors.

sudo dracut --regenerate-all --force
dracut-install: ERROR: failed to install ‘/lib/$LIB/liblsp.so’ for ‘/bin/bash’
dracut-install: ERROR: installing ‘/bin/bash’
dracut: FAILED: /usr/lib/dracut/dracut-install -D /var/tmp/dracut.29406D/initramfs -l /bin/bash
dracut-install: ERROR: failed to install ‘/lib/$LIB/liblsp.so’ for ‘/usr/lib/systemd/system-generators/systemd-debug-generator’
dracut-install: ERROR: failed to install ‘/lib/$LIB/liblsp.so’ for ‘/usr/lib/systemd/systemd’
dracut-install: ERROR: failed to install ‘/lib/$LIB/liblsp.so’ for ‘/usr/lib/systemd/systemd-coredump’
dracut-install: ERROR: failed to install ‘/lib/$LIB/liblsp.so’ for ‘/usr/lib/systemd/systemd-cgroups-agent’
dracut-install: ERROR: failed to install ‘/lib/$LIB/liblsp.so’ for ‘/usr/lib/systemd/systemd-shutdown’
(and the hit’s just keep on coming for another hundred lines or so…)

How do I fix this?

Who is the Dracula guy, and why does he hate me?

1 Like

What is the version of the problematic kernel?

rpm -q -a kernel\* | sort

Check free space and the package integrity:

df -h
sudo rpm -V -a kernel\*

Try to remove/reinstall the broken kernel packages.

Ok, so it is the last TWO packages (5.8.13 & 5.8.14) which are problematic:

    [heinrich@fedorap72 ~]$ rpm -q -a kernel\* | sort

I have plenty of space:

    [heinrich@fedorap72 ~]$ df -h
    Filesystem                               Size  Used Avail Use% Mounted on
    devtmpfs                                 7.7G     0  7.7G   0% /dev
    tmpfs                                    7.7G  782M  7.0G  10% /dev/shm
    tmpfs                                    7.7G  2.5M  7.7G   1% /run
    /dev/mapper/fedora_localhost--live-root   69G   13G   53G  20% /
    tmpfs                                    7.7G  3.0M  7.7G   1% /tmp
    /dev/nvme0n1p2                           976M  257M  652M  29% /boot
    /dev/mapper/fedora_localhost--live-home  838G   79G  717G  10% /home
    /dev/nvme0n1p1                           599M   21M  579M   4% /boot/efi
    tmpfs                                    1.6G   20K  1.6G   1% /run/user/42
    tmpfs                                    1.6G  140K  1.6G   1% /run/user/1000

[heinrich@fedorap72 ~]$ sudo rpm -V -a kernel\*
[sudo] password for heinrich: 
.M.......  g /boot/System.map-5.8.14-200.fc32.x86_64
.M.......  g /boot/initramfs-5.8.14-200.fc32.x86_64.img
.......T.    /lib/modules/5.8.14-200.fc32.x86_64/modules.builtin.alias.bin
.M.......  g /boot/System.map-5.8.13-200.fc32.x86_64
.M.......  g /boot/initramfs-5.8.13-200.fc32.x86_64.img
.......T.    /lib/modules/5.8.13-200.fc32.x86_64/modules.builtin.alias.bin
.M.......  g /boot/System.map-5.8.12-200.fc32.x86_64
.M.......  g /boot/initramfs-5.8.12-200.fc32.x86_64.img
.......T.    /lib/modules/5.8.12-200.fc32.x86_64/modules.builtin.alias.bin

So, I should do?:

    rm -r /boot/System.map-5.8.14-200.fc32.x86_64
    rm -r /boot/initramfs-5.8.14-200.fc32.x86_64.img
    rm -r /lib/modules/5.8.14-200.fc32.x86_64/modules.builtin.alias.bin
    rm -r /boot/System.map-5.8.13-200.fc32.x86_64
    rm -r /boot/initramfs-5.8.13-200.fc32.x86_64.img
    rm -r /lib/modules/5.8.13-200.fc32.x86_64/modules.builtin.alias.bin

My 5.8.12 works just fine.

1 Like
sudo dnf remove kernel\*-5.8.1{3,4}
sudo dnf upgrade kernel

If this doesn’t help, it’s best to file a bug.
You can use the working kernel while waiting for updates.

1 Like

Well, I tried that and it pootched everything. Nothing worked.

Thank God for backups!

I just re-installed F32 (but this time with BTRFS) and I am back to work.


1 Like

That’s unfortunate, but this means the issue was more serious.
It might be damaged package database, or corrupted boot/root file system.
This is usually due to faulty hardware and/or unexpected power failures.