Unable to install flatpak as 'user'

Hi, I’m on Silverblue 31. I’m trying to install flatpak as normal user, without success. The same flatpak is OK to install without ‘user’ option. I’m trying following command:
flatpak install --user fedora com.transmissionbt.Transmission

I get “error: No remote refs found similar to ‘fedora'”. Why is this? Am I doing anything wrong?

  • Does a repo exist at ~/.local/share/flatpak/?
  • Does a [remote "fedora"] config exist in ~/.local/share/flatpak/repo/config
    • If not you could try copying that section from the config at /var/lib/flatpak/repo/config

Right, likely missing the remote config for your user. Compare flatpak remotes and flatpak remotes --user.

Thank you both. Indeed, I did not have repo in my user local directory. I figured out that (sorry for not doing my homework :grimacing:). I added repo with,
flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo --user
Same for fedora repo. Issue resolved.

Still, as a normal user, I would have liked that I only install repo once, not have a separate repo for user and system and be able to install using --user option.

If you mostly want to install things as the user, you can remove the repos from the system install to avoid accidentally installing things there.

Hi Ryan,
Thanks. As I am the only user (and trying on virtualbox) I guess it doesn’t mater much. I wanted to check the user install feature.