Twitch doesn't work on Fedora 39 with KDE, can't install ffmpeg due to conflict

,

Twitch on chromium doesn’t work showing the following error

This video is either unavailable or not supported in this browser. (Error #4000)

So after some search, i’ve tried to install ffmpeg but gives me conflict errors

Error: 
 Problem: problem with installed package libswscale-free-6.0-12.fc39.aarch64
  - package ffmpeg-libs-6.0-16.fc39.aarch64 from rpmfusion-free conflicts with libswscale-free provided by libswscale-free-6.0-12.fc39.aarch64 from @System
  - package ffmpeg-libs-6.0-16.fc39.aarch64 from rpmfusion-free conflicts with libswscale-free provided by libswscale-free-6.0-11.fc39.aarch64 from fedora
  - package ffmpeg-libs-6.0-16.fc39.aarch64 from rpmfusion-free conflicts with libswscale-free provided by libswscale-free-6.0-12.fc39.aarch64 from updates
  - package ffmpeg-6.0-16.fc39.aarch64 from rpmfusion-free requires ffmpeg-libs(aarch-64) = 6.0-16.fc39, but none of the providers can be installed
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages)

Do i need some specific steps to do or there is something missing at the moment?

1 Like

You can either install libavcodec-freeworld, which is intended to be used with Fedora’s ffmpeg-free packages, or you can switch to RPM Fusion’s ffmpeg:

sudo dnf swap ffmpeg-free ffmpeg --allowerasing
1 Like

really thank you, that’s solve my problem