Troubles installing Tigervnc Fedora 39

Hi everyone,

I am trying to install tigervnc for Fedora 39, following what is reported in /usr/share/doc/tigervnc/HOWTO.md , but when I try to start vnc, the result is :

systemctl status vncserver@:1
○ vncserver@:1.service - Remote desktop service (VNC)
Loaded: loaded (/usr/lib/systemd/system/vncserver@.service; enabled; preset: disabled)
Drop-In: /usr/lib/systemd/system/service.d
└─10-timeout-abort.conf
Active: inactive (dead) since Sat 2023-11-18 17:36:00 CET; 47s ago
Duration: 30ms
Process: 50059 ExecStartPre=/usr/libexec/vncsession-restore :1 (code=exited, status=0/SUCCESS)
Process: 50075 ExecStart=/usr/libexec/vncsession-start :1 (code=exited, status=0/SUCCESS)
Main PID: 50084 (code=exited, status=0/SUCCESS)
CPU: 41ms

Nov 18 17:36:00 fedora.fritz.box systemd[1]: Starting vncserver@:1.service - Remote desktop service (VNC)…
Nov 18 17:36:00 fedora.fritz.box systemd[1]: Started vncserver@:1.service - Remote desktop service (VNC).
Nov 18 17:36:00 fedora.fritz.box systemd[1]: vncserver@:1.service: Deactivated successfully.
and vnc does not run.

Can anyone help me?

Thank you in advance.

Alkaddy

This method still works on Fedora 39:
I'm trying to run a remote desktop without monitor but i cannot find out how it works - #4 by vgaetera

Thank you for your prompt reply.

Unfortunately, it didn’t work either, with the same behaviour:

sudo systemctl status vncserver@:2
[sudo] password for alkaddy:
○ vncserver@:2.service - Remote desktop service (VNC)
Loaded: loaded (/usr/lib/systemd/system/vncserver@.service; enabled; preset: disabled)
Drop-In: /usr/lib/systemd/system/service.d
└─10-timeout-abort.conf
Active: inactive (dead) since Sun 2023-11-19 08:14:21 CET; 2h 3min ago
Duration: 5.016s
Process: 74965 ExecStartPre=/usr/libexec/vncsession-restore :2 (code=exited, status=0/SUCCESS)
Process: 74976 ExecStart=/usr/libexec/vncsession-start :2 (code=exited, status=0/SUCCESS)
Main PID: 74984 (code=exited, status=0/SUCCESS)
CPU: 40ms

Nov 19 08:14:16 fedora.fritz.box systemd[1]: Starting vncserver@:2.service - Remote desktop service (VNC)…
Nov 19 08:14:16 fedora.fritz.box systemd[1]: Started vncserver@:2.service - Remote desktop service (VNC).
Nov 19 08:14:21 fedora.fritz.box systemd[1]: vncserver@:2.service: Deactivated successfully.

Any other way to fix it?

Thank you

tail ~/.vnc/*.log

Warning: Could not resolve keysym XF86NavInfo
Errors from xkbcomp are not fatal to the X server
xinit: XFree86_VT property unexpectedly has 0 items instead of 1
xinit: connection to X server lost

waiting for X server to shut down
Sun Nov 19 12:25:29 2023
ComparingUpdateTracker: 0 pixels in / 0 pixels out
ComparingUpdateTracker: (1:-nan ratio)

Thank you!

Check the log:

cat ~/.vnc/*.log

This is the complete ~/.vnc/xxyy
.log file :

Using desktop session gnome

New ‘fedora.fritz.box:2 (alessandro)’ desktop is fedora.fritz.box:2

Starting desktop session gnome

Xvnc TigerVNC 1.13.1 - built Nov 2 2023 00:00:00
Copyright (C) 1999-2022 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.
Underlying X server release 12014000

Sun Nov 19 12:51:34 2023
vncext: VNC extension running!
vncext: Listening for VNC connections on all interface(s), port 5902
vncext: created VNC server for screen 0
The XKEYBOARD keymap compiler (xkbcomp) reports:

Warning: Could not resolve keysym XF86CameraAccessEnable
Warning: Could not resolve keysym XF86CameraAccessDisable
Warning: Could not resolve keysym XF86CameraAccessToggle
Warning: Could not resolve keysym XF86NextElement
Warning: Could not resolve keysym XF86PreviousElement
Warning: Could not resolve keysym XF86AutopilotEngageToggle
Warning: Could not resolve keysym XF86MarkWaypoint
Warning: Could not resolve keysym XF86Sos
Warning: Could not resolve keysym XF86NavChart
Warning: Could not resolve keysym XF86FishingChart
Warning: Could not resolve keysym XF86SingleRangeRadar
Warning: Could not resolve keysym XF86DualRangeRadar
Warning: Could not resolve keysym XF86RadarOverlay
Warning: Could not resolve keysym XF86TraditionalSonar
Warning: Could not resolve keysym XF86ClearvuSonar
Warning: Could not resolve keysym XF86SidevuSonar
Warning: Could not resolve keysym XF86NavInfo
Errors from xkbcomp are not fatal to the X server
xinit: XFree86_VT property unexpectedly has 0 items instead of 1
xinit: connection to X server lost

waiting for X server to shut down
Sun Nov 19 12:51:37 2023
ComparingUpdateTracker: 0 pixels in / 0 pixels out
ComparingUpdateTracker: (1:-nan ratio)

Thank you very much.

1 Like

It looks the same for me until this line:

Let’s check your permissions and configuration:

ls -a -l -Z ~/.vnc; cat ~/.vnc/config

ls -a -l -Z ~/.vnc; cat ~/.vnc/config
total 12
drwx------. 1 alessandro alessandro unconfined_u:object_r:vnc_home_t:s0 68 Nov 19 12:25 .
drwx------. 1 alessandro alessandro unconfined_u:object_r:user_home_dir_t:s0 290 Nov 19 17:43 …
-rw-------. 1 alessandro alessandro unconfined_u:object_r:vnc_home_t:s0 87 Nov 19 11:57 config
-rw-r–r–. 1 alessandro alessandro system_u:object_r:vnc_home_t:s0 1961 Nov 19 12:51 fedora.fritz.box:2.log
-rw-------. 1 alessandro alessandro unconfined_u:object_r:vnc_home_t:s0 8 Nov 19 12:17 passwd
session=gnome
securitytypes=vncauth,tlsvnc
geometry=2000x1200
localhost=0
alwaysshared

1 Like

Here’s a similar issue:
[SOLVED] TigerVNC error: xinit connection to X server lost / Applications & Desktop Environments / Arch Linux Forums

Thank you, but, actually, I don’t have that file.

It must depends on something else.

I have no idea.

1 Like

Can anyone help me with the following issue?:

sudo systemctl status vncserver@:2
[sudo] password for alkaddy:
○ vncserver@:2.service - Remote desktop service (VNC)
Loaded: loaded (/usr/lib/systemd/system/vncserver@.service; enabled; preset: disabled)
Drop-In: /usr/lib/systemd/system/service.d
└─10-timeout-abort.conf
Active: inactive (dead) since Sun 2023-11-19 21:46:10 CET; 20h ago
Duration: 3.916s
Process: 123936 ExecStartPre=/usr/libexec/vncsession-restore :2 (code=exited, status=0/SUCCESS)
Process: 123947 ExecStart=/usr/libexec/vncsession-start :2 (code=exited, status=0/SUCCESS)
Main PID: 123955 (code=exited, status=0/SUCCESS)
CPU: 43ms

Nov 19 21:46:06 fedora.fritz.box systemd[1]: Starting vncserver@:2.service - Remote desktop service (VNC)…
Nov 19 21:46:06 fedora.fritz.box systemd[1]: Started vncserver@:2.service - Remote desktop service (VNC).
Nov 19 21:46:10 fedora.fritz.box systemd[1]: vncserver@:2.service: Deactivated successfully.

It’s if vnc started and immediately stopped.

Thank you very much in advance.

Alkaddy

Try the following:

  • Log in the remote host locally using a physical keyboard and monitor and verify the GNOME session works correctly.
  • Decrease the server resolution in the VNC config: geometry=800x600

Thank you.

I am not sure I knowhow to “Log in the remote host locally using a physical keyboard and monitor and verify the GNOME session works correctly”

Can you help me?

Thank you very much.

I tried doing what you suggested:

gnome-connections vnc://host:5902

(gnome-connections:164230): Gtk-WARNING **: 17:27:30.384: GtkFlowBox with a model will ignore sort and filter functions

(gnome-connections:164230): Gtk-CRITICAL **: 17:27:52.458: gtk_container_add: assertion ‘GTK_IS_WIDGET (widget)’ failed

Along this message a GNOME desktop popped up but no connection could be established.

Before doing that I reduced the server resolution to 800x600

Thank you very much.

This reproduced for me today (Jan 17, 2024) with a fresh Fedora 39 installation.

  • systemctl restart vncserver@:3 fails with the documented “xinit lost connection” message.
  • This works: /usr/sbin/vncserver :3
  • Putting the configurations used in the linked solution does not change the situation.
  • Disabling SE Linux does not change the situation.
  • Fedora 36 systems upgraded to 39 continue to work.

There is something very subtle broken in Fedora 39 with regards to Tiger VNC via systemd. :\

Any insights would be much appreciated.

To reproduce, fresh install and enable tigervnc-server per instructions.

Thanks, all!

journalctl -xe | grep vnc

  • systemctl cat vncserver@:3 : Displays the active configuration.
  • systemctl status vncserver@:3 : Shows service status and recent logs.

If you have the upgraded system, maybe you can diff the configs and see what changed. I thought about a longer approach with dnf history list or creating a list of packages and diff them, but that is for the upgraded machines and the change I think is in the configs ( since upgraded F36 works but Fresh F39 does not work )

On the working (upgraded) system and the not-working (fresh install) system the systemd files appear identical (and are stock, I do not edit them):

cat vncserver@:3|md5sum 
7dad4a468f8a2454bb15528a101bffd6  -

Journal output is unsurprising and not super helpful…

○ vncserver@:3.service - Remote desktop service (VNC)
     Loaded: loaded (/usr/lib/systemd/system/vncserver@.service; disabled; preset: disabled)
    Drop-In: /usr/lib/systemd/system/service.d
             └─10-timeout-abort.conf
     Active: inactive (dead)

Jan 17 09:15:41 pyn1 systemd[1]: vncserver@:3.service: Deactivated successfully.
Jan 17 09:27:10 pyn1 systemd[1]: Starting vncserver@:3.service - Remote desktop service (VNC)...
Jan 17 09:27:10 pyn1 systemd[1]: Started vncserver@:3.service - Remote desktop service (VNC).
Jan 17 09:27:10 pyn1 systemd[1]: vncserver@:3.service: Deactivated successfully.
Jan 17 09:27:33 pyn1 systemd[1]: Starting vncserver@:3.service - Remote desktop service (VNC)...
Jan 17 09:27:33 pyn1 systemd[1]: Started vncserver@:3.service - Remote desktop service (VNC).
Jan 17 09:27:34 pyn1 systemd[1]: vncserver@:3.service: Deactivated successfully.
Jan 17 10:00:19 pyn1 systemd[1]: Starting vncserver@:3.service - Remote desktop service (VNC)...
Jan 17 10:00:19 pyn1 systemd[1]: Started vncserver@:3.service - Remote desktop service (VNC).
Jan 17 10:00:20 pyn1 systemd[1]: vncserver@:3.service: Deactivated successfully.

~/.vnc/*log is interesting, but I can’t isolate any of the error messages before xinit’s final failure as the cause…

.vnc/pyn1:3.log': file truncated
Using desktop session xfce

New 'pyn1:3 (sam)' desktop is pyn1:3

Starting desktop session xfce


Xvnc TigerVNC 1.13.1 - built Dec 20 2023 00:00:00
Copyright (C) 1999-2022 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.
Underlying X server release 12014000


Wed Jan 17 10:01:30 2024
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5903
 vncext:      created VNC server for screen 0
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Could not resolve keysym XF86CameraAccessEnable
> Warning:          Could not resolve keysym XF86CameraAccessDisable
> Warning:          Could not resolve keysym XF86CameraAccessToggle
> Warning:          Could not resolve keysym XF86NextElement
> Warning:          Could not resolve keysym XF86PreviousElement
> Warning:          Could not resolve keysym XF86AutopilotEngageToggle
> Warning:          Could not resolve keysym XF86MarkWaypoint
> Warning:          Could not resolve keysym XF86Sos
> Warning:          Could not resolve keysym XF86NavChart
> Warning:          Could not resolve keysym XF86FishingChart
> Warning:          Could not resolve keysym XF86SingleRangeRadar
> Warning:          Could not resolve keysym XF86DualRangeRadar
> Warning:          Could not resolve keysym XF86RadarOverlay
> Warning:          Could not resolve keysym XF86TraditionalSonar
> Warning:          Could not resolve keysym XF86ClearvuSonar
> Warning:          Could not resolve keysym XF86SidevuSonar
> Warning:          Could not resolve keysym XF86NavInfo
Errors from xkbcomp are not fatal to the X server
xinit: XFree86_VT property unexpectedly has 0 items instead of 1
/usr/bin/startxfce4: X server already running on display :3
DRI3 not available
failed to load driver: zink
xfce4-session-Message: 10:01:30.687: SSH authentication agent is already running
xinit: connection to X server lost

waiting for X server to shut down  ComparingUpdateTracker: 0 pixels in / 0 pixels out
 ComparingUpdateTracker: (1:-nan ratio)

Running the vncsession command directly shows the same warnings and errors but does not fail on xinit, it succeeds, runs and I can connact. Very curious.

I’m glad you have both systems up, it will help you narrow down what difference is in the packaging. I’m not glad about diff a list of packages to see what changed/not changed and possible solutions. . . :hourglass: consuming. I will look around, but probably not much help since you have the ideal set up of broken and working builds.

Check DRI3 support: cat /proc/dri/drivers to list available DRM drivers.
DRI3 modules: Ensure necessary DRI3 modules are loaded. Run lsmod | grep drm to see loaded modules and check for missing ones.
Kernel parameters: Investigate potential kernel parameters interfering with DRI3. Review logs (journalctl -b ) for warnings related to DRI3 or drivers.

I think DRI is misleading in this case. Starting vncsession <user> :3 directly succeeds. Here’s the log up to the first message from the XFCE window manager…

Using desktop session xfce

New 'pyn1:3 (sam)' desktop is pyn1:3

Starting desktop session xfce


Xvnc TigerVNC 1.13.1 - built Dec 20 2023 00:00:00
Copyright (C) 1999-2022 TigerVNC Team and many others (see README.rst)
See https://www.tigervnc.org for information on TigerVNC.
Underlying X server release 12014000


Wed Jan 17 10:39:15 2024
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5903
 vncext:      created VNC server for screen 0
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Could not resolve keysym XF86CameraAccessEnable
> Warning:          Could not resolve keysym XF86CameraAccessDisable
> Warning:          Could not resolve keysym XF86CameraAccessToggle
> Warning:          Could not resolve keysym XF86NextElement
> Warning:          Could not resolve keysym XF86PreviousElement
> Warning:          Could not resolve keysym XF86AutopilotEngageToggle
> Warning:          Could not resolve keysym XF86MarkWaypoint
> Warning:          Could not resolve keysym XF86Sos
> Warning:          Could not resolve keysym XF86NavChart
> Warning:          Could not resolve keysym XF86FishingChart
> Warning:          Could not resolve keysym XF86SingleRangeRadar
> Warning:          Could not resolve keysym XF86DualRangeRadar
> Warning:          Could not resolve keysym XF86RadarOverlay
> Warning:          Could not resolve keysym XF86TraditionalSonar
> Warning:          Could not resolve keysym XF86ClearvuSonar
> Warning:          Could not resolve keysym XF86SidevuSonar
> Warning:          Could not resolve keysym XF86NavInfo
Errors from xkbcomp are not fatal to the X server
xinit: XFree86_VT property unexpectedly has 0 items instead of 1
Failed to import environment: Process org.freedesktop.systemd1 exited with status 1
/usr/bin/startxfce4: X server already running on display :3
error: XDG_RUNTIME_DIR is invalid or not set in the environment.
DRI3 not available
failed to load driver: zink
xfce4-session-Message: 10:39:18.796: SSH authentication agent is already running
error: XDG_RUNTIME_DIR is invalid or not set in the environment.
DRI3 not available
failed to load driver: zink

(xfwm4:5813): xfwm4-WARNING **: 10:39:18.968: Unsupported GL renderer (llvmpipe (LLVM 17.0.6, 256 bits)).

Do I understand this correctly? You started the vncsession <user> :3 so on :3 not on :0 ? But vncext: created VNC server for screen 0 :thinking: So the error about it already running is because it’s on 3 or 0 ?

Failed to import environment: Process org.freedesktop.systemd1 exited with status 1 /usr/bin/startxfce4: X server already running on display :3 :thinking: :thinking:

Can you start it on :0 ? instead of :3 ?