Remote desktop - works only with attached display

could you help me with problem with shared desktop? I want to connect to PC with Fedora 37 (Gnome) and it works, only when the PC with F37 has attached display. Without display is not possible to connect to F37.

Konfiguration of F37 is attached in screenshot.

Thank you very much.

1 Like

You should mention whether you need Wayland.

My current headless server is running Fedora 37 using the TigerVNC Service. In the distant past, batch processes that needed access to a X-server to generate image artifacts could use Xvfb. I wonder if GNOME40 Headless Virtual would help for your use case.

Hi George,
thank you very much for your answer. No, I dont need to have Wayland, but I spent a lot of time with solving of this problem, so I would prefer some easy solution.

But now back to your link… thanks to your idea about Gnome headless virtual I was looking for the solution and found this command:

mutter --wayland --headless --virtual-monitor 1920x1080

…and because I am not very experienced with that, so I want to ask you: Is that fix for my problem?

EDIT: No, the command doesnt work.

mutter --wayland --headless --virtual-monitor 1024x768
libmutter-Message: 22:31:49.665: Running Mutter (using mutter 43.0) as a Wayland display server
libmutter-Message: 22:31:50.726: Added device '/dev/dri/card1' (i915) using no mode setting.
libmutter-Message: 22:31:50.770: Created gbm renderer for '/dev/dri/card1'
libmutter-Message: 22:31:50.770: Boot VGA GPU /dev/dri/card1 selected as primary
libmutter-Message: 22:31:51.024: Added virtual monitor Meta-0
libmutter-Message: 22:31:51.092: Using public X11 display :0, (using :2 for managed services)
libmutter-Message: 22:31:51.092: Using Wayland display name 'wayland-0'

(mutter:2834): libmutter-WARNING **: 22:31:51.405: Lost or failed to acquire name org.gnome.Mutter.ScreenCast

(mutter:2834): libmutter-WARNING **: 22:31:51.405: Lost or failed to acquire name org.gnome.Mutter.RemoteDesktop

(mutter:2834): libmutter-WARNING **: 22:31:51.499: Failed to create colord device for 'xrandr-MetaVendor-MetaVirtualMonitor-0x00': failed to obtain org.freedesktop.color-manager.create-device auth

See: Gnome Remote Desktop Issue 90.

Upstream discussion mentions that mutter --wayland --headless --virtual-monitor 1024x768 fails on Fedora 36.

Yet another approach is a cheap dummy monitor dongle.

I already bought HDMI dummy dongle and it works. The last problem is, that I can not connect, when the user is not logged. Firstly the user has to login to Gnome and then is RDP available. I googled a lot, but no solution for this issue.

I means, that after reboot you have to connect display, keyboard, mouse and logon user… after that you can use RDP.

The tigervnc recipe starts a vncserver for each configured user. If you just close the viewer the vncserver stays up so you can reconnect as desired.

I’m retired, but many of my younger colleagues have left VNC in favour of browser based tools like Rstudio-server and jupyter.

Yes, you are right with VNC. But problem is, that on Fedora 37 is Wayland and VNC doesnt work properly. I already tried that. Thats why I use integrated RDP.

Can you be more specific about your VNC problems? I use an old imac with Fedora 37 for the nice display, and have tigervnc server on the headless system, also Fedora 37. I have tried several VNC viewers. Some had issues in the past. I’m currently using gnome-onnections:

Installed Packages
Name         : gnome-connections
Version      : 43.0
Release      : 1.fc37
Architecture : x86_64
Size         : 876 k
Source       : gnome-connections-43.0-1.fc37.src.rpm
Repository   : @System
From repo    : fedora
Summary      : A remote desktop client for the GNOME desktop environment
URL          :
License      : GPLv3+
Description  : Connections is a remote desktop client for the GNOME desktop environment.

The problem is not client (I already tested several clients Remmina, Gnome-connections, etc), but VNC server. When I want to connect, so I see just black screen. I used tigervnc as well.

I have tigervnc server on my headless box, and have been doing so for years. Maybe poke around with an ssh session in your server to find some errors from tigervnc server (dmesg, journalctl, ~/.vnc/*.log. Here is my ~/.vnc/X.1.log:

Using desktop session gnome

New 'X:1 (U)' desktop is X:1

Starting desktop session gnome

Xvnc TigerVNC 1.12.0 - built Jul 23 2022 00:00:00
Copyright (C) 1999-2021 TigerVNC Team and many others (see README.rst)
See for information on TigerVNC.
Underlying X server release 12014000, The X.Org Foundation

Sat Dec 24 09:48:07 2022
 vncext:      VNC extension running!
 vncext:      Listening for VNC connections on all interface(s), port 5901
 vncext:      created VNC server for screen 0
xinit: XFree86_VT property unexpectedly has 0 items instead of 1

Sat Dec 24 09:48:08 2022
 ComparingUpdateTracker: 0 pixels in / 0 pixels out
 ComparingUpdateTracker: (1:-nan ratio)

Sat Dec 24 11:58:37 2022
 Connections: accepted:
 SConnection: Client needs protocol version 3.8
 SConnection: Client requests security type VeNCrypt(19)
 SVeNCrypt:   Client requests security type TLSVnc (258)

Sat Dec 24 11:58:43 2022
 VNCSConnST:  Server default pixel format depth 24 (32bpp) little-endian rgb888
 VNCSConnST:  Client pixel format depth 24 (32bpp) little-endian rgb888

I haven’t investigated "xinit: XFree86_VT property unexpectedly has 0 items instead of 1` since
things are working. might be useful.

Yeah, I was using VNC for years too. But when Wayland appeared, so the problems appeared too. I suppose, that you use Xorg and according to me, this is the reason why VNC works for you.

I have wayland on my desktop box, tigervnc server is Xorg. This gives me the remote desktop in a Gnome Window. So far I have only been able to use Wayland on the “headless” system by connection a monitor and working locally.

Using remote desktop in a sway session gives a full-screen version of the remote X-Gnome session instead of a window in my current desktop.

I spend a lot of time in Rstudio, which is basically a tiled interface and needs full screen (so Gnome contributes vert little). I am investigating using the wayvnc server which requires a wlroots Wayland compositor.

George, thank you for very comprehensive explanation, but I already gave it up:( I tried wayvnc server as well, but not successfuly.

I think, we can close this topic.

Thank you very much for your help.