Tried all deployment methods

When I saw the release notice I downloaded the images and tried all deployment methods that are relevant to us. We need it locally in vSphere, no need for AWS etc. for us.

First, an installation using the ISO file in a vSphere VM worked fine and on the first try.

Then I had a little more work with the OVA. Only after digging around and finally finding
[https://github.com/coreos/docs/blob/master/os/booting-on-vmware.md#vmware-guestinfo-interface]
I figured out how to pass the ignition information properly and it worked.
My first couple of attempts had only ended in a system crash.
I think that when the FCOS installer has a problem it should print usefull error messages and halt gracefully.
I guess that documentation for VMware (currently there is none) will be added later.

Then I tried PXE and also after a couple of tries got FCOS PXE live boot working.
Given the way one passes an URL for the ignition file, I assumed that the installer would then use some curl or similar code to retrieve it.
But apparently, the code is very limited and can only work via http: and not with ftp: URLs to the ignition file.

But I cannot get PXE installation working even with the same basic and working ignition file that worked fine with the ISO and OVA installations and the PXE live boot.
All I get is a crashing system, looking similar like when I had wrong ignition data passed to the OVA. But since all I can see is the physical console with its 25 lines and quite more error messages seem to be printed too quickly to read them, I cannot see why exactly it fails.
Is there a way to debug this?

Does it not prompt for an emergency shell? Can you connect via serial console and adding console=ttyS0 to the kcmdline? That way at least you’d get to read the output for analysis.

I did the PXE installation also in a VM. So, no serial console. :slight_smile:
However, I don’t know why, but shortly after my posting it finally worked.
So the PXE installation is done as well.

All I would now need to be happy with it would be open-vm-tools in FCOS. :smiley:

Unfortunately, no more reply here.
Fortunately, found the answer to my last problem in issue #70 now.