TotoLink A2000UA USB WIFI DUAL BAND ADAPTER not working on Fedora 30

Hello everyone, this is my first post I hope you’ll have mercy on me :smiley:

So today I bought a dual band usb adapter which is unfortunately not working on my Fedora :frowning:.

I did some research but I still have no clue about how could I make it work :confused: install many wifi drivers, recompile kernel and etc… but it’s still not working, that’s why I’m asking help to you guys.

Thank you.


According to this:

Its based on the RTL8812BU, so this driver should do it:

DKMS installation instructions should work.

Thanks Tom.

1 Like

Hello tjdoyle,

Thank you it works like a charm ! :slight_smile:

One more question, how can I know manage my wifi settings ? It appears as 2 different wifi source, from gnome I can’t manage disable one of them :confused:

Thank you again


Nevermind I found a gnome package that can easily solved this problem

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.