Tor browser strange characters


After the last update my Tor Browser (RPM)

display strange characters



It’s a bug from Tor upstream as mentioned here

Since it’s look like a failed to render the fonts, there a big chances that this default tor rendering non standard font—something like aAbBcC things.

I tried to install torbrowser-launcher and after that I go to:

$ cd /home/<your-user-name>/.local/share/torbrowser/tbb/x86_64/tor-browser_en-US/Browser/fonts
$ ls
... list of fonts

You will find lot of NotoSans fonts in there.

Then I delete all NotoSans variant only fonts except NotoEmoji-Regular.ttf and NotoSansSC-Regular.otf.

Open again the Tor, and font now rendered correctly.

Suggestion: Instead delete the fonts like what I did, I suggest you just move it to another directories as backup.


it’s easily fixable:
in the fonts.conf:


<!-- Font directory list -->


it should read:

<dir prefix="relative">fonts</dir>

Sixpack13’s solution worked for me. BUT…
Finding the fonts.conf file was NOT easy. It’s in…
./{the directory where tor was extracted}/Browser/TorBrowser/Data/fontconfig
From there, edit the file, find the html string for fonts and edit it like he noted above.

1 Like

Thanks to all for the solution.

I had my box where TB is running currently offline, so …
else I had provided (correct engl. ?) the path too

Thanks for the solution, taking a look now.

In case anyone is wondering, the goofy characters are placeholders with Unicode character references - 0068 for h, 0074 for t, etc.

They didn’t fix it in the latest update to Tor Browser, so yet again I had to fix it myself by applying the fix found posted here in the forum. Humans…

1 Like

May be they are prioritizing on how the browser to be more anonymous across the platform so they stick with current configuration.

Also maybe by adding prefix they think in some degree it will leak your system identities but don’t quote me on that, it’s just maybe.