Time of day is 2 hours fast

Recently, I’m noticing that the time is often two hours fast. I’m dual-booting with Windows 11, but this problem is not occuring when I boot into Windows. I rarely do so.
If I go into the date and time settings, disable automatic date and time and re-enable it, the correct time is set.
Before messing with timedatectl I would like to know what is happening. Any ideas?

By default, Linux expects CMOS clock in UTC timezone.
While Windows expects CMOS clock in Local timezone.

Either you override Windows using RegistryEditor, or override Linux using timedatectl, so that they can agree on CMOS clock timezone.


What does timedatectl say? Could you share the output please?

1 Like

I ran timedatectl and got:

           Local time: Thu 2022-10-13 14:22:08 CEST
       Universal time: Thu 2022-10-13 12:22:08 UTC
             RTC time: Thu 2022-10-13 14:22:08
            Time zone: Europe/Malta (CEST, +0200)

System clock synchronized: yes
NTP service: active
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode cannot be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
‘timedatectl set-local-rtc 0’.

I ran the command as requested and now it says:

           Local time: Thu 2022-10-13 14:22:50 CEST
       Universal time: Thu 2022-10-13 12:22:50 UTC
             RTC time: Thu 2022-10-13 12:22:50
            Time zone: Europe/Malta (CEST, +0200)

System clock synchronized: yes
NTP service: active
RTC in local TZ: no

1 Like

I heard that Windows 11 has problems with the hardware clock in UTC even with the registry change that used to be suggested for Windows 10.

Based on personal experience, to override in Windows 11 is more complicated than Windows 10.

Overriding Linux with timedatectl should be easier.

But I always override Windows.

You can make timedatectl use bios time as local time

I tested it previously
cause i had the same problem on other computer with ubuntu

Not true. Windows, as does linux, can work with either, but some apps do not work properly and logging is off with recorded times if the cmos clock or RTC is set to local time in either system.

Both systems expect the cmos and RTC to be synced and to be set to UTC and then the time within the system to be set to the proper time zone. That way everything time related just works, including syncing time with ntp or equivalent.

1 Like