Install Fedora 31 on computer not connected to internet, fedora assumes system clock is set to UT. Cannot overide either in MB setup or Linux

Yesterday I installed Fedora 31 on a system with Gigabyte B450M DS3H main board. The MB clock is set to current Australian Eastern Standard Time. I set the timezone to AEST Sydney but the time displayed is 10 hours ahead of what it should be, ie. the system clock is interpreted as being set to UT(GMT).

At the moment AEST is 15:35 on 30/05/2020 but display on desktop says 01:35 on 1/05.

I cannot find anyway to tell the system otherwise either in the main board setup or in Fedora.

I have another gripe illustrated by this query. I would like to add tags such as “systemclock” “UT” “timezone” … etc but none such exist.

This computer is not currently connected to the internet as I am using it in a room too far from my Wifi router.

1 Like

I use this site for detailed Fedora setup step by step guides:

You can use timedatectl to control if your RTC (also called CMOS clock) is in Local Time Zone or in UTC timezome.

Linux and macOS prefers RTC in UTC while Windows prefers RTC in Localtime

Use timedatectl to manage timezones in Fedora

# timedatectl --help

imedatectl [OPTIONS…] COMMAND …

Query or change system time and date settings.

status Show current time settings
show Show properties of systemd-timedated
set-time TIME Set system time
set-timezone ZONE Set system time zone
list-timezones Show known time zones
set-local-rtc BOOL Control whether RTC is in local time
set-ntp BOOL Enable or disable network time synchronization

systemd-timesyncd Commands:
timesync-status Show status of systemd-timesyncd
show-timesync Show properties of systemd-timesyncd

-h --help Show this help message
–version Show package version
–no-pager Do not pipe output into a pager
–no-ask-password Do not prompt for password
-H --host=[USER@]HOST Operate on remote host
-M --machine=CONTAINER Operate on local container
–adjust-system-clock Adjust system clock when changing local RTC mode
–monitor Monitor status of systemd-timesyncd
-p --property=NAME Show only properties by this name
-a --all Show all properties, including empty ones
–value When showing properties, only print the value

See the timedatectl(1) man page for details.

List Australian Timezones available

timedatectl list-timezones | grep Australia


Set time computer timezone

# sudo timedatectl set-timezone Australia/Melbourne
  • Enter sudo password
  • no output is good result

Change RTC to Local
# sudo timedatectl set-local-rtc 1

After this, timedatectl will give you a warning:

# timedatectl

Local time: Thu 2020-04-30 17:59:59 AEST
Universal time: Thu 2020-04-30 07:59:59 UTC
RTC time: Thu 2020-04-30 17:59:59
Time zone: Australia/Melbourne (AEST, +1000)
System clock synchronized: yes
NTP service: active
RTC in local TZ: yes

Warning: The system is configured to read the RTC time in the local time zone.
This mode cannot be fully supported. It will create various problems
with time zone changes and daylight saving time adjustments. The RTC
time is never updated, it relies on external facilities to maintain it.
If at all possible, use RTC in UTC by calling
‘timedatectl set-local-rtc 0’.