Terminal backup command for connected android devices (adb=Android debug bridge)

I try to enter my smartphone Gigaset 290 through the Fedora folder enviroment. Becourse I want to make a Factory recovery backup before rooting and installing another OS.

Why can I not see the contained folders with data ?

Is there a way to acces through the Terminal. Enter path folder like CD - PWD -ls commands ?

Shall I run the android fastboot installation with SUDO in this folder GS290

Is there a Bash-command to create a backup folder on connected devicefolders (locked. Need root acces ) data with the Terminal ?

I tried https://linuxcommand.org/lc3_lts0030.php

[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ LS

bash: LS: command not found…
Similar command is: ‘ls’
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ ls
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ pwd
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ ls
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ cd .
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$

adb - Android Debug Bridge have you installed it?
(I was reading in a other topic of you that you wanted to install it.)

If yes adb |grep -i -A 2 backup or just adb and scrolling a bit.


I’m not quite sure what I’m doing wrong. But after being in the Terminal G290 folder by sudo and typing in the command you gave me. It ask for --help

[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ adb |grep -i -A 2 backup 
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ adb |grep -i
Usage: grep [OPTION]... PATTERNS [FILE]...
Try 'grep --help' for more information.
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ --help
bash: --help: command not found...
Failed to search for file: Failed to load /etc/yum.repos.d/fedora-33-unstable.repo: Key file does not start with a group
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ adb |grep -A
grep: option requires an argument -- 'A'
Usage: grep [OPTION]... PATTERNS [FILE]...
Try 'grep --help' for more information.
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ grep--help
bash: grep--help: command not found...
Failed to search for file: Failed to load /etc/yum.repos.d/fedora-33-unstable.repo: Key file does not start with a group
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ adb |grep --help
Usage: grep [OPTION]... PATTERNS [FILE]...
Search for PATTERNS in each FILE.
Example: grep -i 'hello world' menu.h main.c
PATTERNS can contain multiple patterns separated by newlines.

When I’m looking at the last Example above it needs an argument after -i
What kind of argument is that ?

What does this means:

$ADB_MDNS_AUTO_CONNECT comma-separated list of mdns services to allow auto-connect (default adb-tls-connect)

sudo dnf install android-tools

Then connect your mobile device by USB and post the output:

adb devices -l
[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ **`sudo dnf install android-tools**`
Warning: failed loading '/etc/yum.repos.d/fedora-33-unstable.repo', skipping.
No read/execute access in current directory, moving to /
Last metadata expiration check: 2:19:21 ago on Wed 26 May 2021 06:23:58 PM CEST.
Package android-tools-1:30.0.5p1-1.fc33.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
1 Like

[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ adb device -l
adb: unknown command device

[TemplePusher@jonas-bloch-riisgaard mtp:host=Gigaset_GS290_GS290CTLC02450]$ adb devices -l
List of devices attached

Nothing appears. Strange

1 Like
1 Like

I can not enter the phone with out accepting the terms of service which I do not want to agree in. I bought this Gigaset290 4 month ago becourse I thought European phones wasn’t forced by “centralised software” by the Giantbrowser company. I bought the hardware and want to choose which OS I’m using. The problem is that it is locked and I can’t debug in developers mode. Thats why I try to go through the terminal and only using open source and free off tracking and commercial interests.

I’m looking for an emulator. Becourse I think the phones software is secured.
I do not want to use the preinstalled Android version as it isn’t a free one but full of controlling trackers. As I read about.

Now I have to find another way than being forced to do something against my will.

I need to create a back up as I do not want to brick it.


1 Like

I’m afraid that accepting the terms is necessary for adb to proceed.
Also as far as I understand, adb backup does’t include the entire firmware.
You may need to perform a block-level backup to preserve the current firmware.
However, I believe that Android doesn’t expose its block storage on purpose.
Looks like this problem is tricky and may not have a simple solution.

1 Like

Ok then. I understand that making things more difficult makes it imposible for me as a beginner in this case.

Thank you for helping me here. I was really stocked for some time with that issue and has being working to solve it the whole day.

I thought wasn’t that hard using bash and linux. But I really do have a lot to learn.

1 Like

another thing is now to back up with out using google drive and signing in using a Gmail. impossible! :zipper_mouth_face: