Talk: Boot might fail with “vmlinuz[…] has invalid signature” in atomic desktops

This is a discussion topic for the following Common Issue:

You can discuss the problem and its solutions here, but please note that debugging and technical feedback should primarily go to the issue trackers (e.g. Bugzilla) linked in the Common Issue, because that’s the place that developers watch, not here.

If there are any updates/changes/amendments for the Common Issue description, which you believe should be performed, please post it here.


Please see the Common Issue for solution/workarounds:

1 Like

Note: If you’re going to reinstall (listed as one of the methods above), make sure you have backups!

Explanation: Anaconda currently insists on wiping your /var/home subvolume no matter what you do. It will first complain that it has to be deleted if you try to set things up in advanced mode. If you go to the advanced blivet GUI instead, with some effort you can set up things properly. However, due to another bug, it’ll fail to install, so you’ll have to reboot back to Anaconda and wipe it out too (and go with the defaults), to have a working system.

(I went through this a week ago, coincidentally. :persevere: Thankfully, I had just made a nearly complete backup…)

So, to restate, as this is important: if you’re going to reinstall, be sure to make a current backup on another disk before doing so and also make sure it works. You’re going to need it.

Yes, Anaconda should not nuke your home directory when you reinstall. But it does, on Atomic versions. :pensive:


Yeah that would be cool, it’s there an open issue about that already?

That said (for non-atomic distros) one would IMHO not have expected that user data is kept on reinstallation as everything was always wiped. But for atomic distros that certainly makes sense.

@garrett Thanks for useful info, I linked it in the issue description.

@rugk The issue is now published, thanks for writing it up!


This just happened to me when updating to 40.20240617.0 (2024-06-17T00:42:18Z)

I repaired it manually as per the article mentioned above.

Added atomic-desktops

Hi! Thank you for this writeup and the instructions to fix it. This happened to my Thinkpad T480 on updating to 40.20240620.0.

I followed the instructions to copy the updated bootloader manually, and it worked fine!

*EDIT: I had asked if a bug had been filed, but I re-read the writeup, and there is one. Sorry, I wrote before reading.

Thanks again!

1 Like

I just had the same problem on my T14, but I solved it by running the commands mentioned in the other thread.

1 Like