System won't boot after update | Fedora 40 | Mesa 24.1

Starts loading sddm and then goes back to a black screen with a blinking underscore (_). I can get to terminal, that’s about it.

Although I can restore a rescuezilla backup from last week, as soon as I update the same thing is going to happen.

I tried the rescue option in grub options, but that just gets to screen with error messages:
Timed out waiting for device dev-zram0.device _ /dev/zram0
Dependency failed for dev-zram0.swap
Dependency failed for system-zram-setup@zram0.service

Sddm won’t start from command line either

And I can’t boot old kernels as the same problem occurs of a black screen

Any suggestions??


1 Like

There’s a couple things that we need to look at, I’m going through the thread now to repost.

I’ll try a couple of things he suggested there but difference is after upgrading no kernels work even older ones boot to a blank screen and display manager doesn’t come up with any kernel

Still no go, tried many suggestions but it still won’t boot, restored rescuezilla backup for now

Is there any way to do a something similar to dnf update by using a nightly iso, I.e similar to what windows used to have with windows system repair.

Or am I best to wait a few weeks and see if enough people report similar problems (a lot of people on reddit are reporting similar problems after that update) and hope when I then run dnf upgrade fixes may have been pushed out to resolve the issue ( this issue happened on my system with every single beta up to release candidate 2 and this is first time I’ve had the issue come up again since the final release)

Not to be rude, but this is pretty vague, Did you produce logs, what exactly did you try? Posting them here would help in troubleshooting? Sorry to say but :

:tux: “Hey Guys, Tried a bunch of stuff from a bunch of places and nothing worked”

Makes things harder to troubleshoot :upside_down_face:

What do you mean by this? dnf has a ton of features, history, rollback, swap, downgrade etc. I haven’t used Windows for personal use in 15yrs+ . . . so I don’t recall those features.

Can you link some of those threads? If people on Reddit are reporting an issue, it would be nice to do some outreach and see if we can come to a solution.

1 Like

My post, other people have suggested fixes on that thread and I’ve tried all of them. Some other people say fix works others saying it doesn’t work

Are also tried disabling zram and changing display manager before upgrade

Are you actually on Ultramarine?

No, F40

So, someone there also posted this :

I had this issue and what fixed it for me was

Sudo Systemctl enable gdm; Sudo Systemctl disable sddm; Sudo Systemctl reboot
If you tried this can you post the logs here. Would love to see them.

journalctl -xe | fpaste --raw-url

Post that url link here, so we can see the full logs

1 Like

I’ve returned to a backup now, my network adaptor wasn’t working from a terminal after the upgrade anyway so wouldn’t be able to do fpaste --raw-url.

Anyways I will repost a thread in a week or two because I need a break from it as stressing out and I’ve got bad anxiety and Insomnia at best of times

I have a solution kinda, PC repair guy spent hours trying to fix it. The issue??? WAYLAND. Kde and Gnome bomb out on wayland back to black screen.

He setup X11 on KDE, boots straight in as does Gnome. No issues.

Not sure why it’s suddenly bombing out on wayland after an update as it’s been working fine up till the update a week or so back.

Worthy of a Bug against Both KDE and Gnome teams. Wayland is default in both so this is important. I have not experienced any issues so it would be good to know from your experience.

You know that this is not a good solution right?

You did not offer the needed details, what variant (KDE Spin?), what hardware etc.

If you are on “Workstation” i.e. GNOME you should use gdm and try what @hamrheadcorvette suggested.

Just using X11 is not a solution, as not many other people have this issue, so it might just be a misconfigured login manager.


Added missing-infos

I’ve used sddm, gdm, lightdm with exactly the same issue.

I do not run any spin both KDE and Gnome were installed via the everything ISO.

In terms of hardware I have an AMD A10-7700K Radeon R7 integrated gpu , 16gb DDR3, Asus motherboard.

Apart from the 40 betas which I had an issue with till release candidate 2, I have had no issues whatsoever with fedora 40 and black screen on boot until a week ago when some updates were pushed.

No issues on 39 ever with black screen on boot. either.

Okay and what did you use last? Did you use the desktops with Xorg?

It can be that the display managers may rely on X11 as they did in the past. SDDM switched to Wayland only on Plasma6 I think.

Added amdgpu, everything-netinstall, f40, gdm, gnome, kde, lightdm, sddm, wayland and removed missing-infos

Yes I used the desktops with Xorg. And GDM is currently now set as my display manager