Stuck in emergency-mode

Hello, something happened that caused my laptop to no longer boot normally into Fedora.

Instead, after loading a short amount of time, I’m presented with a terminal-looking screen and the prompt:
You are in emergency mode. After logging in, type “journalctl -xb” to view system logs, “systemctl reboot” to reboot, “systemctl default” or “exit” to boot into default mode.
Give root password for maintenance
(or press Control-D to continue):

The prompt is slightly different than it was before, as a result of following this guide as a potential solution (specifically steps 5-6 I think).

I’m not sure if I made a mistake, but supplying the new password did not unlock emergency-mode.
Typing Control-D only resets the same prompt – no change.

I have a bootable USB of Fedora-29, but am unsure of what to do with it to fix this problem.

Thank you for your time.


Try check file system .

1- add this to boot “rd.break=pre-mount”

2- check file system ,example :
(First run “blkid” to list partitions )

fsck -f /dev/mapper/fedora-home

fsck -f /dev/mapper/fedora-root

fsck -f /dev/sda2

3- run “exit”

Thank you for your response.

I entered the boot, added the statement “rd.break=pre-mount”, and proceeded.

Presented with the bash, I ran “blkid” and found 5 different partitions:

I ran “fsck -f” for all of these and accepted the corrections it offered for two problems:
/dev/mapper/fedora_localhost–liveroot/ had incorrect “Free blocks count” and “Free inodes count”.

And /dev/sda2/ reported:
Dirty bit is set. Fs was not properly mounted and some data may be corrupt.
1) Remove dirty bit
2) No action

For this I entered “1” and then performed the changed “y”.
After fsck was done, I simply ran “exit”.

After “exit”, the console gave me these errors:
[FAILED] Failed to start File System Check on /dev/mapper/fedora_localhost–live-home.
[DEPEND] Dependancy failed for /home.
[DEPEND] Dependancy failed for Local File Systems.
[DEPEND] Dependancy failed for Mark the need to relabel after boot.

The console then returned to the original “You are in emergency mode.” prompt.

1 Like

not from live system

1 Like

The recommended way to check file system:


I apologize for such a late reply.

To the best of my memory, I solved my problem with the following:

  1. I re-followed the guide I originally linked in the OP, and changed the root password. However I avoided the last step of exiting the maintenance environment.
  2. While in the same environment, I then re-followed Youssef Sourani’s solution to the OP, and fs-checked all of my partitions. If I saw it, it got fs-checked.
  3. lastly, I exited and rebooted.

This time it worked, and I’m not entirely sure why, (compared to my previous attempts).

In a previous attempt, I followed Vladislav Grigoryev’s advice in the post above and added fsck.mode=force to the boot parameter, although I don’t remember seeing this parameter again on my later successful attempt.

Thank you to all who provided help, I greatly appreciate it.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.