Stremio hardware accelerated video decoding | F40 | Flatpak | Nvidia

I have NVidia GTX 950, intel i5 CPU, 8 GB RAM. I installed Fedora Workstation, updated, installed Nvidia 550 drivers, enabled RPM fusion repos. I followed guides from net and installed gstreamer, ffmpeg codecs. I can see mpv using hw decoding. I check with Mission Center and Nvtop.
But Stremio flatpak is not using hw video decoding. Videos are mostly x265,x 264. This only happens in Fedora. Is there anything to do?

Welcome to :fedora:

Where did you ge the Drivers from ? Nvidia website or RPMFusion ? This can sometimes mean you installed from a nother source and not the supported way through RPMFusion.

I did not get from Nvidia site. I installed by:
sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda
This is specific to Fedora. I tried in Arch derivatives, debian derivatives. They all use hw decoding either by flatpak or AUR.

1 Like

Added f40 and removed workstation

According to the site :

Following options are available in the Player section

    Hardware accelerated decoding - Select this option to turn on hardware accelerated decoding
    Launch player in a separate window - Select this option if you want to start Stremio player in a separate window, might not always work

Can you verify this is enabled ?

Also using Flatseal :

Check if this option is enabled for you.

HW accelerated decoding is enabled in Stremio settings.

Do you have Flatseal to check?

No, I will install it soon. Thanks.

I installed flatseal. GPU acceleration is enabled.

1 Like

I was wrong about Debian flatpak had hw decoding. I installed LMDE today and saw it was not
doing hw decoding. So it’s only Arch AUR install has hw decoding for Stremio.

If I’m not mistaken, those two are just encoders.

Check here and see what codecs your GPU supports. Compare it to the details of the video you expect it to decode.

I installed with the script from Stremio-Install-Scripts/ at master · alexandru-balan/Stremio-Install-Scripts · GitHub. It says for Fedora 31 but worked for Fedora 40. I now have Stremio with hardware decoding actually working.


I see that this solution is not related to the flatpak version of the application, am I wrong?

The GPU you have supports the following coders/decoders (codecs). How does the flatpak version of the app behave with the formats supported by your device?

GeForce GTX 750/950-960: MPEG-1, MPEG-2, VC-1, VP8, VP9 (8 bit), H.264, H.265 4:2:0 (8 bit, 10 bit)

Would be good to know if the