Streaming HTML video seek backwards - image lags behind

When I watch video on a streaming site and try to rewind/seek backwards, the image is frozen, while the sound plays normally. The image slowly catches up, stuttering a bit, within about 10-15 seconds.
This is only the case when I seek back, i.e. click any location behind the current playback point, while the video is playing.
If I pause the video first, then click a point further back, then wait a few seconds (minimum 5 or so) and then continue playback, it resumes normally. It also works normally with immediate seek forward
While it’s not exactly broken, it’s still annyoing and something I’ve never seen on other distros (btw what’s the reason Fedora uses the Cisco implemantation of HTML video streaming?).

The problem usually doesn’t occur on proprietary/commercial streaming technoclogies, like Netflix or Youtube (don’t know if YT still delivers standard HTML video…).
Any other site exhibits this problem.
What’s the preferred way of providing hardware info here? I’m giving it a try wiht inxi, let me know if something’s missing:

~$ inxi -G
Graphics:
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] driver: amdgpu
    v: kernel
  Device-2: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 23.2.3
    compositor: kwin_wayland driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,radeon,vesa dri: radeonsi gpu: amdgpu,amdgpu
    resolution: 1920x1080
  API: EGL v: 1.5 drivers: radeonsi,swrast
    platforms: gbm,wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.3.1 renderer: AMD
    Radeon RX 6600M (radeonsi navi23 LLVM 17.0.6 DRM 3.54
    6.6.9-200.fc39.x86_64)
  API: Vulkan v: 1.3.268 drivers: radv,llvmpipe surfaces: xcb,xlib,wayland

It appears that installing the non-free version of the ffmpeg package from RPMfusion solved it for me. To do it, I followed the instructions described here:
https://rpmfusion.org/Howto/Multimedia

I was directed there from this forum thread.
It’s not the exact same issue I had, but the same fix worked.
Lucky I found it, because this problem was becoming a dealbreaker between me and Fedora.