Stop GNOME keyring from resetting its password for autologin

I am using GNOME and since I am the only one with physical access to my desktop PC I also use GNOMEs autologin feature.
This works reasonably well, but after login I get the prompt to authenticate myself.
This can temporarily can be worked around using GNOME keyring (seahorse) and setting the password to “”.
This however is not persistent and only works until the next update.

Is there a way to enable automatic login without any password indefinetly?

I have searched the web and found out that I am not the only one suffering from this issue but did not find any good solutions.

Unlock screen by bluetooth device proximity has been on my “todo” list for too long. I’m a proponent of very long pass phrases, so I can see the advantage of proximity methods.