Gnome-Keyring not unlocking automatically

Fully updated Fedora 30
First few boots it worked fine, but now the login keyring isn’t getting unlocked automatically. It is also interesting that if Déjà Dup fails even one time because it can’t unlock the ssh key, it will fail any next backups, since it thinks that the directory it backs up to is the backup directory of an another computer.

I tried some things unsuccessfully: trying to inject the password to gnome-keyring-daemon and turning off automatic login (single-user, disk encrypted, auto-login on normally).

Edit: apparently after next boot the keyring couldn’t even be unlocked manually (same issue before last Fedora reinstall, but then messed around with nextcloud remembering login and couldn’t make a new one what could be unlocked), after deleting it, logging out and back in I found myself a new Login keyring. So I guess a workaround to when your Login keyring stops unlocking by itself is to before reboot unlock it manually, back everything in it up, delete it and log out, log in.

Though… it now seems to happen every 3-5 reboots. Don’t know the cause. I am suspecting, that it is Déjà Dup.

1 Like

Hi @jtagcat! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

I’ve had maybe not-quite-similar problem with gnome-keyring once or twice in the past. In my case I’ve changed my account’s password, but to unlock gnome-keyring I had to provide old password.

I’ve resolved this by manually changing gnome-keyring’s password with the help of seahorse gui program.

I’m not sure if it’s applicable in your case (I haven’t used autologin), but it’s one thing you can try/play with.


I have never changed the password on this installation. It now some boot works, some boot not, I have turned off Déjà Dup for the time being.
Any ideas for what logs to look at?

You can still try changing / maybe removing gnome-keyring password (I’m not sure removing it is a good idea) to see if it helps you in some way.

How can I ‘remove’ the password? I can delete the login keychain, but currently I’m just locked out again.

Set an empty one? I haven’t tried it )