Steam issue in Fedora 40 Plasma

I just completed a new PC build with all AMD and finished installing Fedora 40 Plasma. This is the first time with an AMD system as I previously was using Intel CPU and NVIDIA GPU. I attempted to install Steam via dnf but when I launch Steam it doesn’t appear, it does for split second and is gone. However, I notice the icon in the taskbar tray is still there. I removed Steam and tried installing the flatpak version but there was an error after install, something about steam-devices not present. So, I removed the flatpak, installed Steam again through dnf again but this time, thinking it was a Wayland issue, I installed plasma-workspace-x11 and logged in with X11, but am experiencing the same behavior.
What is the preferred way to install Steam these days? And how do I get it working properly?

Here are my system specs:

CPU: AMD Ryzen 7 7700 (16) @ 5.39 GHz
GPU 1: AMD Radeon RX 6800 [Discrete]
GPU 2: AMD Raphael @ 0.60 GHz [Integrated]

From where did you install steam?
I have no problems with steam when installed from the rpmfusion-nonfree-steam repo when using x11 on an f40 workstation install.

I simply made certain that the rpmfusion-nonfree-steam repo appears when running dnf repolist then install steam with sudo dnf install steam

That message (Missing permission for input device) is not an error but a reminder to install additional package if you need Steam devices support, like for a gamepad: Flathub Wiki - Missing permissions for input devices. The Fedora version of the command is

sudo dnf install steam-devices

You can run Steam in Konsole (CLI) to get more debug info.

Steam from Fedora:

steam

Steam from Flatpak:

flatpak run com.valvesoftware.Steam

I have rpmfusion repos, but I don’t have rpmfusion-nonfree-steam. How do I get that repo? That’s the first I have heard of a Steam specific repo from rpmfusion.

In the gnome software center the ‘hamburger menu’ at the upper right allows accessing software repositories. In there select the 3rd party repos then the steam repo.

I use Plasma.

Here’s a list of what I have installed:

[ed@b26354: ~]$ sudo dnf repolist | grep fusion
rpmfusion-free                                 RPM Fusion for Fedora 40 - Free
rpmfusion-free-updates                         RPM Fusion for Fedora 40 - Free - Updates
rpmfusion-nonfree                              RPM Fusion for Fedora 40 - Nonfree
rpmfusion-nonfree-updates                      RPM Fusion for Fedora 40 - Nonfree - Updates

The full list of repos should not be very long

Plasma should have a similar software center to enable the repos.

Also, sometimes steam does not work well in wayland and works better with x11.

Added kde-plasma

Yeah, as mentioned in my original post, I made sure to use X11 instead of Wayland.
I’m just confused as to why Steam repo wasn’t installed when I installed the rpmfusion repos.

Update:
So, I tried to start Steam from command line and it launches just fine. Doesn’t work running from the Plasma menu. Weird.

I found a fix for this, in case someone else runs into this issue in the future.

You have to edit the steam.desktop file and change the PrefersNonDefaultGPU value from true to false. Then, update the the desktop database file with sudo update-desktop-database /usr/share/applications/steam.desktop command.

sudo vim /usr/share/applications/steam.desktop
PrefersNonDefaultGPU=false
sudo update-desktop-database /usr/share/applications/steam.desktop

Note: after updating the database I got a gripe that it could not be updated but it still worked.

I think the reason for this required changed is because I have an integrated GPU on my motherboard and discrete GPU (AMD Radeon RX 6800) installed.
Just a theory…

1 Like

Cool that you got it working.
I’ll also try that.
I tried from command line and then run Valheim but it crashes when loading a game.
Do you have problems with some of your games?

I had to use the flatpak version for Valheim to work, but I don’t like that and when using MangoHud with it the colors seem reduced to 16 bit.

Many other users report issues with steam on linux lately, quite a few of them specific to Fedora 40 Plasma.

So far, every game I have installed in Steam via ProtonDB (select game>Properties>Compatibility>Force the use of a specific Steam Play compatibility tool>Proton 9.0-1) has worked without issues. I’ve installed and played in Steam via the above method the following games:
Cyberpunk 2077
Marvel’s Spider-Man: Miles Morales
Marvel’s Spider-Man Remastered
Tom Clancy’s Ghost Recon Wildlands

I’m still running Plasma in X11. I have no plans of using Wayland anytime soon because of constant wonkiness I have experienced and have heard from others. Also, to be clear, I installed Steam via dnf not flatpak as, I think, it is the preferred method.

1 Like

i followed this and im still having the same issue.

There are two ways to solve this:

  1. Edit the steam.desktop file as described earlier
  2. Start steam via a terminal

Both methods should work.

Please also note that this change may be required after every Steam update. I just had to make the change again after a recent update.