Startup Error Message

I dual boot Windows and fedora. When the system starts up, an error message stating something about “unable to…Fedora…”. It’s too brief to read. Then the Grub Menu appears and start up proceeds normally. Is there a log file or something that will tell me what that is about and what is generating it? I can’t tell that the error is causing any problems, but I would like to find out.

There are several commands to see the logs.

dmesg will show all the kernel messages from the beginning of the boot, time stamped from the beginning of that boot.
journalctl -b 0 will show all the logged messages of every sort from the beginning of the current boot.

Neither of those will show messages that appear before grub actually starts the boot, so it may be a message from bios or a very early stage of the grub boot that you are seeing.

Once the system has booted you may be able to see some information that might assist with sudo efibootmgr as that can tell us a little about the bios boot menu which may be where that message is originating.

Please post the output of sudo efibootmgr in the preformatted text tags using the </> button on the tool bar above.

1 Like

Thanks for your reply. Sorry it took so long to get back.
I took a look at dmesg and journelctl dtl -b 0. Both have instances of “loading Fedora signing key”. But, nothing else containing the word “Fedora”.
Here is contents of suto efibootingmgr:

bash-5.2$ sudo efibootmgr
[sudo] password for bill: 
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0004,0002,0001
Boot0000* nobara	HD(2,GPT,bf05288c-d4bb-4fa9-9bc4-c2acef7b2a50,0x109000,0x32000)/File(\EFI\FEDORA\SHIMX64.EFI)57494e444f5753000100000088000000780000004200430044004f0042004a004500430054003d007b00390064006500610038003600320063002d0035006300640064002d0034006500370030002d0061006300630031002d006600330032006200330034003400640034003700390035007d00000034000100000010000000040000007fff0400
Boot0001* Linux Firmware Updater	HD(2,GPT,bf05288c-d4bb-4fa9-9bc4-c2acef7b2a50,0x109000,0x32000)/File(\EFI\nobara\fwupdx64.efi)
Boot0002* Fedora	HD(2,GPT,bf05288c-d4bb-4fa9-9bc4-c2acef7b2a50,0x109000,0x32000)/File(\EFI\fedora\shimx64.efi)
Boot0004* nobara	HD(6,GPT,dd7ab080-fbc1-3545-a47d-c9b2df5b98d6,0xc350800,0x200000)/File(\EFI\FEDORA\SHIMX64.EFI)

I don’t see anything there that looks like an errror.

Is there a way to pause the boot screen so that the entire message can be read? I tried ctrl s and that paused the grub menu but not the preceeding screen where the error message occurs.

A couple of issues from efibootmgr

  • No entry for windows.

  • Boot0000 and Boot0002 are effectively duplicates.

  • Boot0000 contains what looks like some windows stuff, which is unexpected.

  • Boot0004 refers to a second ESP file system on partition 6 where the other entries refer to the ESP file system on partition 2

The problem has now escalated to the point that the machine will no longer boot at all. I don’t know if the issues are related, but I’m just going to reinstall.
Thanks for your assistance.

Boot0000 and boot0004 are nobara and not fedora. Nobara is a modified version of fedora that is specifically targeted for gaming and I suggest that you contact them for support since the errors are seen when booting their modified kernel.

Note that boot0000 and boot0002 use the same disk for booting but boot0004 uses a different disk.

1 Like

Interestingly enough I just tried to install the Nobara-37-GNOME-2023-01-13.iso into a VM and it refuses to boot with uefi. I switched to bios and it then booted.

The installer used is calamares, not the same as fedora which uses anaconda.
The several 3rd party packages that you must agree to before installing are not fedora.

Using nobara separates your system far enough from fedora that many may be unable to provide detailed support so the best location for support with a nobara system is the nobaraproject where you got the distrol

Thanks for the info. I have installed a different distro and all is working well.
I appreciate your help.