Sporadic Authentication Required popup

Every now and then this pops up randomly:


Any idea what causes it?

It seems you’re running a virtual machine but your user isn’t in the libvirt group (or whatever group necessary for you hypervisor). Adding you user to the right group should make this unnecessary.

It pops up without me doing anything involving virtual machines though. Just out of the blue it pops up.

Is there any way to see what process is opening it?

I guess a bit more Information would not be a bad idea.
Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

On a other topic you replied the above. So I just can guess that you still talk about Silverblue ?!
If you not had time yet, please also read #start-here, so you have a idea what’s useful information to help you.

journalctl -f -u polkit.service should provide the log information.

1 Like
  Kernel: 5.18.16-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.3.1
    Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: Dell product: XPS 8950 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 0R6PCT v: A01 serial: <superuser required> UEFI: Dell
    v: 1.4.0 date: 06/09/2022
  Device-1: hidpp_battery_0 model: Logitech M720 Triathlon Multi-Device Mouse
    charge: 10% (should be ignored) status: discharging
  Device-2: hidpp_battery_1 model: Logitech K350
    charge: 50% (should be ignored) status: N/A
  Info: 16-core (8-mt/8-st) model: 12th Gen Intel Core i9-12900K bits: 64
    type: MST AMCP arch: Alder Lake rev: 2 cache: L1: 1.4 MiB L2: 14 MiB
    L3: 30 MiB
  Speed (MHz): avg: 2952 high: 4812 min/max: 800/5200:3900 cores: 1: 2759
    2: 2879 3: 4284 4: 4464 5: 2213 6: 3578 7: 4757 8: 2620 9: 3162 10: 2512
    11: 3695 12: 1981 13: 4812 14: 2942 15: 4265 16: 2337 17: 1654 18: 2806
    19: 2235 20: 1708 21: 1548 22: 2094 23: 1660 24: 3888 bogomips: 152985
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Lite Hash Rate] vendor: Dell
    driver: nvidia v: 515.57 arch: Ampere bus-ID: 0000:01:00.0
  Device-2: Dell Integrated_Webcam_5M_IR type: USB driver: uvcvideo
    bus-ID: 1-13.4:80
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:
    loaded: nvidia unloaded: fbdev,modesetting,vesa gpu: nvidia,nvidia-nvswitch
    resolution: 1: 1920x1080~60Hz 2: 1920x1080~60Hz 3: 2560x1440~60Hz
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.57 direct render: Yes
  Device-1: Intel Alder Lake-S HD Audio vendor: Dell driver: snd_hda_intel
    bus-ID: 1-13.2:84 v: kernel bus-ID: 0000:00:1f.3
  Device-2: NVIDIA GA104 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1
  Device-3: Logitech H600 [Wireless Headset] type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Dell S2722DZ type: USB driver: hid-generic,snd-usb-audio,usbhid
    bus-ID: 1-13.3:81
  Sound Server-1: ALSA v: k5.18.16-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek Killer E3000 2.5GbE vendor: Rivet Networks driver: r8169
    v: kernel port: 3000 bus-ID: 0000:03:00.0
  IF: enp3s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 0000:04:00.0
  IF: wlp4s0 state: up mac: <filter>
  IF-ID-1: br-88b8dbfbea34 state: down mac: <filter>
  IF-ID-2: br-c5922386a724 state: down mac: <filter>
  IF-ID-3: br-d683f952e2e8 state: down mac: <filter>
  IF-ID-4: docker0 state: down mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:5
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 bus-ID: 0000:00:0e.0
  Local Storage: total: 1.84 TiB used: 215.33 GiB (11.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM9A1 NVMe 1024GB
    size: 953.87 GiB temp: 39.9 C
  ID-2: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB
  ID-1: / size: 209.15 GiB used: 190.48 GiB (91.1%) fs: xfs dev: /dev/dm-0
    mapped: fedora_desktop--isk3kll-root
  ID-2: /boot size: 1014 MiB used: 328 MiB (32.3%) fs: xfs
    dev: /dev/nvme0n1p7
  ID-3: /boot/efi size: 196 MiB used: 106.7 MiB (54.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: zram size: 8 GiB used: 6.54 GiB (81.8%) dev: /dev/zram0
  ID-2: swap-2 type: partition size: 20 GiB used: 8.06 GiB (40.3%)
    dev: /dev/dm-1 mapped: fedora_desktop--isk3kll-00
  System Temperatures: cpu: 36.0 C mobo: 29.0 C gpu: nvidia temp: 46 C
  Fan Speeds (RPM): cpu: 5514 mobo: 694 gpu: nvidia fan: 0%
  Processes: 732 Uptime: 9d 18h 40m Memory: 31.07 GiB used: 26.46 GiB (85.2%)
  Init: systemd target: graphical (5) Compilers: gcc: 12.1.1 Packages: 26
  note: see --pkg Shell: fish v: 3.5.0 inxi: 3.3.19

I thought “workstation” implied ‘not silverblue’, so I guess my post on that thread was unclear. Bottom line I don’t have Silverblue, I’m running the regular Fedora 36 install.

At one point I created a VM in Gnome Boxes, and then I tried working with virt-manager. I haven’t done anything with them in a long time. I just noticed that when I run virt-manager it opens the same popup. But what’s bothering me is that the popup comes up out of the blue without me doing anything with VMs.

I just the popup and I ran the command and only one line is recent:

Aug 23 02:35:48 naftoli-dell polkitd[1162]: Operator of unix-session:2 FAILED to authenticate to gain authorization for action org.libvirt.unix.manage for unix-process:545305:3963702 [<unknown>] (owned by unix-user:naftoli)

(I pressed Cancel.)

for unix-process:545305:3963702

When this happens, open up another terminal

ps -ef | grep -v grep | grep -e process id -e process id

That should get you the process that is running.

Is part of that placeholder text?

In particular is 545305:3963702 like PPID:PID or something else entirely?

At the time IIRC I tried ps -fp X where X was either number and didn’t get anything.

Then again this was after I canceled the popup so maybe I have to try it in another VT while the popup is open (because it blocks the entire DE VT).