Can't open Nautilus as root

When ever I press Ctrl L and type admin:/// to open Nautilus as root I get this massage:
Screenshot from 2024-06-09 16-13-18
it use to work now it doesn’t, I’m the only user on my pc.

I don’t and never would suggest that anyone open nautilus as root!

Nautilus is the file manager and when running as root it would have the ability to quickly destroy a users system by some inadvertant action.

You should only run that app as your regular user since it would never warn you of an error when running as root but as your regular user it prevents you from modifying/moving/renaming the system files.

What do you suggest I do?

Log in as your regular user and use nautilus from the apps menu (the icon labeled “files”)

I tried what you did in nautilus and it pops up a window that asks for authentication with my users password. If I cancel that it gives the message you asked about. If I use my password then it opens the display for the root of the main file system “/”.

Is your user in the wheel group? (i.e. an administrator)

journalctl -e may show an authentication failure.

2 Likes

What does this question have to do with the original question?

My hypothesis was that the polkit rule for admin:/// doesn’t allow non-admin users (or is broken in that case).

To be clear, nautilus isn’t actually running as root when you do this; it’s communicating with a privileged daemon.

5 Likes

Added gnome, polkit, sudo

You can also launch nautilus from terminal and immediately see a more detailed error message…

nautilus admin:///
5 Likes

Yeah, and I think it has to do with the broken/to restricted Polkit rule to do. Here it seams to have a Change request for such type of errors.
(see F41 change requests)

@marvinp are you using Fedora Silverblue?

Please remove that link as it will show up at the top of the post and it is not related at all.

@computersavvy this is not running Nautilus as root. Such a thing is not even possible on Wayland.

I only know it on KDE where there is kio-admin, and it seems to be the same on GNOME. It is a way to change the permissions of a process/tab to something like root, but more restricted.

@marvinp please file a bug report against the component

If you dont find it, report it against nautilus or gvfs.

1 Like

That looks like the polkit rule uses AUTH_ADMIN if you are wheel.

If you are not, it doesnt ask for the password but gives an error.

So if the user is in wheel is relevant.

@marvinp Please use id to get the needed info.

1 Like

No I’m using fedora 40 workstation

id
uid=1000(faceforradio) gid=1000(faceforradio) groups=1000(faceforradio),10(wheel) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

So what does it do if you know the root password and use su - to become root, which is what I prefer, as sudo wasn’t easily available back when I was learning Linux?

It is erroring out because Wayland doesnt allow to spawn root apps. You can use it through XWayland though. But admin:// is the way to go.

@marvinp I looked in a fresh Silverblue 40 VM

The admin:/// in Nautilus opened a password prompt for me, even though I was in the wheel group

This rule is the relevant one

sudo cat /usr/share/polkit-1/rules.d/org.gtk.vfs.file-operations.rules

It should allow wheel users to do that without a password.

Please open a bug report as I said on Nautilus or gvfs as something is strange here

Are you sure this is the expected behaviour? Even if my user is in the wheel group, I would expect to be prompted for password before being able to perform administrative tasks. Similar to the GNOME Settings app, which requires unlocking with password when adding/modifying users for example.

1 Like

Verify All Installed Packages Against the RPM Database

Here’s the explanation:
daemon/org.gtk.vfs.file-operations.rules.in · master · GNOME / gvfs · GitLab

The second action still requires authentication:
daemon/org.gtk.vfs.file-operations.policy.in.in · master · GNOME / gvfs · GitLab

4 Likes

Also, can just click on the Bar and prepend Admin: as pictured below :

Thanks. I have performed a few tests, and another possibly wrong behaviour is noticeable: duplicating files doesn’t require password, only opening them does (whereas both are priviledged operations). Could this be a related defect?

Example:

  1. Run nautilus admin:/ (from terminal or command prompt)
  2. Authentication required dialog box is displayed (not expected)
  3. Enter correct password and Files app opens, root folder displayed
  4. Navigate to a system folder, e.g. /etc/NetworkManager/
  5. Copy and paste the file NetworkManager.conf
  6. File NetworkManager (Copy).conf file is created, no password required
  7. Open file NetworkManager (Copy).conf
  8. Authentication required dialog box is displayed and file opens for editing upon correct password entry.

Similar when creating folders, renaming files.

1 Like