Software screen freeze after upgrade to f36

Hi Jeff, Please also see this. Thanks:

    [root@localhost ~]# akmods --force && dracut --force
    Checking kmods exist for 6.0.5-200.fc36.x86_64             [  OK  ]
    [root@localhost ~]# nvidia-settings
    ERROR: NVIDIA driver is not loaded
    (nvidia-settings:18088): GLib-GObject-CRITICAL **: 10:33:01.626: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
    ** (nvidia-settings:18088): CRITICAL **: 10:33:01.628: ctk_powermode_new: assertion '(ctrl_target != NULL) && (ctrl_target->h != NULL)' failed
type or paste code here

You might look under /usr/lib/modules/6.0.5-200.fc36.x86_64/extra/ to see of the nvidia modules were actually built. If they don’t exist there then they cannot be used for the 6.0.5 kernel.

If they exist then try sudo modprobe nvidia

Hi Jeff,
OK, they don’t exist. What do we do now? Thanks.

You are not alone in having problems with kernel 6.0.5 and akmod-nvidia-3:520.56.06-1.fc36.x86_64. There is a newer version in rpmfusion-nonfree-updates-testing that seems to work for others, so maybe a simple update done using
sudo dnf upgrade akmod-nvidia --enablerepo=rpmfusion-nonfree-updates-testing will install the newer package and allow the kernel modules to be properly built. It certainly seems worth a try.

Hi Jeff,
                  Thanks.   Here is the output:

 [root@localhost ~]# dnf upgrade akmod-nvidia --enablerepo=rpmfusion-nonfree-updates-testing
Last metadata expiration check: 0:12:55 ago on Wed 02 Nov 2022 09:43:45 AM EDT.
Dependencies resolved.
Nothing to do.

type or paste code here

Try it with refreshing the metadata and disabling the other rpmfusion repo.
dnf upgrade akmod-nvidia --disablerepo=rpmfusion* --enablerepo=rpmfusion-nonfree-updates-testing --refresh (possibly only the refresh may be needed)

I may be wrong but shouldn’t that model graphic card be running the 470 driver instead of the latest 520 drivers.

Hi Jeff,
                    Thanks. Tried it. Here is the output:
    [root@localhost extra]# dnf upgrade akmod-nvidia --disablerepo=rpmfusion* --enablerepo=rpmfusion-nonfree-updates-testing --refresh
    Fedora 36 - x86_64                                                                                                                                                     65 kB/s |  22 kB     00:00    
    Fedora 36 openh264 (From Cisco) - x86_64                                                                                                                              5.9 kB/s | 989  B     00:00    
    Fedora Modular 36 - x86_64                                                                                                                                            134 kB/s |  22 kB     00:00    
    Fedora 36 - x86_64 - Updates                                                                                                                                          104 kB/s |  19 kB     00:00    
    Fedora 36 - x86_64 - Updates                                                                                                                                          1.7 MB/s | 3.5 MB     00:02    
    Fedora Modular 36 - x86_64 - Updates                                                                                                                                  124 kB/s |  21 kB     00:00    
    Fedora Modular 36 - x86_64 - Updates                                                                                                                                   53 kB/s |  42 kB     00:00    
    google-chrome                                                                                                                                                         9.3 kB/s | 1.3 kB     00:00    
    google-chrome                                                                                                                                                         9.8 kB/s | 3.6 kB     00:00    
    inttf Fedora 36 Repo                                                                                                                                                   10 kB/s | 3.0 kB     00:00    
    RPM Fusion for Fedora 36 - Nonfree - Test Updates                                                                                                                      13 kB/s | 3.8 kB     00:00    
    skype (stable)                                                                                                                                                        5.0 kB/s | 2.9 kB     00:00    
    Fedora 36 - x86_64 - VirtualBox                                                                                                                                       1.1 kB/s | 181  B     00:00    
    Dependencies resolved.
    Nothing to do.
    [root@localhost extra]# 

type or paste code here
Tried the 470 version drivers (legacy) from Nvidia site directly but run into same issues of Kernel modules missing. 

Quite possibly the 750M gpu is only supported by the 470 driver though I am not certain.

What version of driver was in use before the upgrade? I assume from your earlier posts you upgraded from 35 to 36, though you do not state such.

The nvidia site shows driver version 418 for that GPU, though I think it likely you were OK with the 470 driver.

When nvidia upgraded the driver from 470 to 495 and beyond they also dropped support for some of the older cards and as suggested by straycat it may be yours is one of those. The 470 and older drivers do NOT support wayland.

Accordingly, if your card is not supported by the newer drivers, you will need to uninstall the newer drivers then install the 470 drivers.
dnf remove *nvidia* --exclude=nvidia-gpu-firmware
followed by
dnf install akmod-nvidia-470xx* --disablerepo=rpmfusion* --enablerepo=rpmfusion-nonfree-updates-testing --refresh
should fix the problem.

I cannot confirm that will work for the 6.0.5 kernel as I do not have that old a GPU, but it should.

Hi Jeff,
              Thanks. So I was able to get NVIDIA 470 to work finally.
But here is the next catch. Now medea just crashes.
 See below

[Fri Nov 04 18:14:46 EDT 2022]: Sourced /home/MD/bin/generic/MedeA.kit
[Fri Nov 04 18:14:46 EDT 2022]:  
[Fri Nov 04 18:14:46 EDT 2022]:    ==> Starting MedeA Client <==
[Fri Nov 04 18:14:46 EDT 2022]:  
/home/MD/Linux-x86_64/MedeA: line 17:  3653 Segmentation fault      (core dumped) /home/MD/bin/Linux-x86_64/MedeA /home/MD/bin/generic/MedeA.kit
/home/ 107 %
As you can see, NVIDIA driver 470 is installed.
[root@localhost ~]# inxi -Fzxx
  Kernel: 6.0.5-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-36.fc36 Desktop: Cinnamon v: 5.2.7 tk: GTK v: 3.24.34 wm: Muffin
    dm: 1: GDM 2: LightDM note: stopped Distro: Fedora release 36 (Thirty
  Type: Portable System: Dell product: XPS 15 9530 v: A09 serial: <filter>
    Chassis: type: 8 serial: <filter>
  Mobo: Dell model: XPS 15 9530 v: A09 serial: <filter> UEFI: Dell v: A09
    date: 07/30/2015
  ID-1: BAT1 charge: 23.4 Wh (38.0%) condition: 61.6/61.0 Wh (100.9%)
    volts: 11.9 min: 11.4 model: Simplo PABAS0241231 serial: <filter>
    status: charging
  Info: quad core model: Intel Core i7-4712HQ bits: 64 type: MT MCP
    arch: Haswell level: v3 rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 986 high: 2296 min/max: 800/3300 cores: 1: 800 2: 798
    3: 800 4: 800 5: 800 6: 800 7: 2296 8: 798 bogomips: 36714
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Dell
    driver: i915 v: kernel arch: Gen-5.75 ports: active: eDP-1
    empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:0416
  Device-2: NVIDIA GK107M [GeForce GT 750M] vendor: Dell driver: nvidia
    v: 470.141.03 arch: Kepler pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 02:00.0
    chip-ID: 10de:0fe4
  Device-3: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-11:7 chip-ID: 0bda:573c
  Display: server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3 driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,vesa alternate: nouveau,nv
    gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 3200x1800 s-dpi: 48
  Monitor-1: eDP-1 model: Sharp 0x13f8 res: 3200x1800 dpi: 235
    diag: 397mm (15.6")
  OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2) v: 4.6 Mesa
    22.1.7 direct render: Yes
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
  Sound Server-1: ALSA v: k6.0.5-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:08b1
  IF: wlp6s0 state: up mac: <filter>
  IF-ID-1: gpd0 state: down mac: N/A
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 bus-ID: 00:1f.2 chip-ID: 8086:282a
  Local Storage: total: 961.33 GiB used: 340.38 GiB (35.4%)
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS541010A7E630
    size: 931.51 GiB speed: 6.0 Gb/s serial: <filter> temp: 35 C
  ID-2: /dev/sdb vendor: LITE-ON IT model: LMS-32S9M-11 MSATA 32GB
    size: 29.82 GiB speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 959.74 GiB used: 340.12 GiB (35.4%) fs: btrfs dev: /dev/sda3
  ID-2: /boot size: 973.4 MiB used: 250.3 MiB (25.7%) fs: ext4
    dev: /dev/sda2
  ID-3: /boot/efi size: 598.8 MiB used: 13.9 MiB (2.3%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 959.74 GiB used: 340.12 GiB (35.4%) fs: btrfs
    dev: /dev/sda3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 50.0 C pch: 54.5 C mobo: N/A
  Fan Speeds (RPM): cpu: 2300
  Processes: 305 Uptime: 7m Memory: 15.52 GiB used: 1.76 GiB (11.4%)
  Init: systemd v: 250 target: graphical (5) default: graphical Compilers:
  gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm Shell: Bash
  v: 5.2.2 running-in: gnome-terminal inxi: 3.3.21
[root@localhost ~]# 

Now that we managed to install the drivers successfully what should we check next? Thanks.

Should I try updating fedora to see if this will fix the issue? I see that there is a new version of kernel.

I checked with MedeA support. They mentioned that MedeA uses the following three libraries:


Did these change in going from f35 to f36? If so, would it be possible to get these libraries for f35? Thanks.

Fedora 35 is now end-of life. The better question is how can we get this to work in Fedora 36 or 37.

Following your suggestion I upgraded my laptop to fedora 37 and the MedeA screen no longer freezes. Thanks. However, I now have another issue. I have been using GlobalProtect for vpn connection. When I type in the portal address, the GlobalProtect window freezes. Any suggestions on correcting this problem?

If you wouldn’t mind creating a new topic for this since it’s a new issue and optionally linking it to this one? I think I might be able to offer some help with that though since I use it for work.

I created a new topic as you suggested. Thanks.
1 Like