Softether VPN client


I’ve switched from Ubuntu 22.04 to Fedora 36 recently. I’m using Softether VPN client to connect to a remote server. It works fine on Ubuntu, but I can’t set it up on Fedora. I’m getting error messages:

grep: /etc/sysconfig/network-scripts/ifcfg-*: No such file or directory
/usr/sbin/dhclient-script: line 706: /etc/resolv.conf: Permission denied

I’ve tried to find out some solutions, but unfortunately it doesn’t help.

Fedora is definitely not Ubuntu :wink:
See the readme file in /etc/sysconfig/network-scripts/readme-ifcfg-rh.txt

cat readme-ifcfg-rh.txt
NetworkManager stores new network profiles in keyfile format in the
/etc/NetworkManager/system-connections/ directory.

Previously, NetworkManager stored network profiles in ifcfg format
in this directory (/etc/sysconfig/network-scripts/). However, the ifcfg
format is deprecated. By default, NetworkManager no longer creates
new profiles in this format.

Connection profiles in keyfile format have many benefits. For example,
this format is INI file-based and can easily be parsed and generated.

Each section in NetworkManager keyfiles corresponds to a NetworkManager
setting name as described in the nm-settings(5) and nm-settings-keyfile(5)
man pages. Each key-value-pair in a section is one of the properties
listed in the settings specification of the man page.

If you still use network profiles in ifcfg format, consider migrating
them to keyfile format. To migrate all profiles at once, enter:

nmcli connection migrate

This command migrates all profiles from ifcfg format to keyfile
format and stores them in /etc/NetworkManager/system-connections/.

Alternatively, to migrate only a specific profile, enter:

nmcli connection migrate <profile_name|UUID|D-Bus_path>

For further details, see:

  • nm-settings-keyfile(5)
  • nmcli(1)

By default on Fedora 36, /etc/resolv.conf is a symlink to a file managed by systemd-resolved, and as such, not many to be edited directly. It is possible to revert to the older behavior:

  • set dns=default in NetworkManager config in /etc
  • stop/disable systemd-resolved
  • remove the symlink sudo rm /etc/resolve.conf
  • restart NetworkManager

This should make the resolv.conf file behave like most other distro’s default.

1 Like