Silverblue f37 - rpm-ostreed stuck in background update loop

I recently isntalled f37 silveblue ( my first real installation of silverblue ) and i started to notice my cpu would randomly start to get high usage

looking at it it seems that rpm-ostreed is stuck in a background update loop ( triggered by gnome-software i think )

% journalctl -l -u rpm-ostreed | egrep "Initiated|Unlocked|idle|Txn|txn" | tail -n 30
Dec 16 11:06:52 fedora rpm-ostree[1694200]: Txn AutomaticUpdateTrigger on /org/projectatomic/rpmostree1/fedora successful
Dec 16 11:06:52 fedora rpm-ostree[1694200]: Unlocked sysroot
Dec 16 11:06:52 fedora rpm-ostree[1694200]: In idle state; will auto-exit in 63 seconds
Dec 16 11:06:52 fedora rpm-ostree[1694200]: Initiated txn RefreshMd for client(dbus:1.115 unit:app-gnome-org.gnome.Software-2838.scope uid:1000): /org/projectatomic/rpmostree1/fedora
Dec 16 11:07:10 fedora rpm-ostree[1694200]: Txn RefreshMd on /org/projectatomic/rpmostree1/fedora successful
Dec 16 11:07:10 fedora rpm-ostree[1694200]: Unlocked sysroot
Dec 16 11:07:10 fedora rpm-ostree[1694200]: In idle state; will auto-exit in 61 seconds
Dec 16 11:07:10 fedora rpm-ostree[1694200]: Initiated txn Upgrade for client(dbus:1.115 unit:app-gnome-org.gnome.Software-2838.scope uid:1000): /org/projectatomic/rpmostree1/fedora
Dec 16 11:07:21 fedora rpm-ostree[1694200]: Preparing pkg txn; enabled repos: ['fedora', 'fedora-cisco-openh264', 'phracek-PyCharm', 'fedora-modular', 'updates', 'updates-modular', 'google-chrome', 'updates-archive'] solvables: 95187
Dec 16 11:07:21 fedora rpm-ostree[1694200]: Txn Upgrade on /org/projectatomic/rpmostree1/fedora successful
Dec 16 11:07:21 fedora rpm-ostree[1694200]: Unlocked sysroot
Dec 16 11:07:21 fedora rpm-ostree[1694200]: In idle state; will auto-exit in 63 seconds
Dec 16 11:07:21 fedora rpm-ostree[1694200]: Initiated txn AutomaticUpdateTrigger for client(dbus:1.115 unit:app-gnome-org.gnome.Software-2838.scope uid:1000): /org/projectatomic/rpmostree1/fedora
Dec 16 11:07:40 fedora rpm-ostree[1694200]: Txn AutomaticUpdateTrigger on /org/projectatomic/rpmostree1/fedora successful
Dec 16 11:07:40 fedora rpm-ostree[1694200]: Unlocked sysroot
Dec 16 11:07:40 fedora rpm-ostree[1694200]: In idle state; will auto-exit in 63 seconds
Dec 16 11:07:40 fedora rpm-ostree[1694200]: Initiated txn RefreshMd for client(dbus:1.115 unit:app-gnome-org.gnome.Software-2838.scope uid:1000): /org/projectatomic/rpmostree1/fedora
Dec 16 11:08:00 fedora rpm-ostree[1694200]: Txn RefreshMd on /org/projectatomic/rpmostree1/fedora successful
Dec 16 11:08:00 fedora rpm-ostree[1694200]: Unlocked sysroot
Dec 16 11:08:00 fedora rpm-ostree[1694200]: In idle state; will auto-exit in 60 seconds
Dec 16 11:08:00 fedora rpm-ostree[1694200]: Initiated txn Upgrade for client(dbus:1.115 unit:app-gnome-org.gnome.Software-2838.scope uid:1000): /org/projectatomic/rpmostree1/fedora
Dec 16 11:08:12 fedora rpm-ostree[1694200]: Preparing pkg txn; enabled repos: ['fedora', 'fedora-cisco-openh264', 'phracek-PyCharm', 'fedora-modular', 'updates', 'updates-modular', 'google-chrome', 'updates-archive'] solvables: 95187
Dec 16 11:08:12 fedora rpm-ostree[1694200]: Txn Upgrade on /org/projectatomic/rpmostree1/fedora successful
Dec 16 11:08:12 fedora rpm-ostree[1694200]: Unlocked sysroot
Dec 16 11:08:12 fedora rpm-ostree[1694200]: In idle state; will auto-exit in 60 seconds
Dec 16 11:08:12 fedora rpm-ostree[1694200]: Initiated txn AutomaticUpdateTrigger for client(dbus:1.115 unit:app-gnome-org.gnome.Software-2838.scope uid:1000): /org/projectatomic/rpmostree1/fedora
Dec 16 11:08:33 fedora rpm-ostree[1694200]: Txn AutomaticUpdateTrigger on /org/projectatomic/rpmostree1/fedora successful
Dec 16 11:08:33 fedora rpm-ostree[1694200]: Unlocked sysroot
Dec 16 11:08:33 fedora rpm-ostree[1694200]: In idle state; will auto-exit in 64 seconds
Dec 16 11:08:33 fedora rpm-ostree[1694200]: Initiated txn RefreshMd for client(dbus:1.115 unit:app-gnome-org.gnome.Software-2838.scope uid:1000): /org/projectatomic/rpmostree1/fedora

if i check the rpm-ostree status it just loops

% while true
do
rpm-ostree status | grep Transaction
sleep 5
done
Transaction: upgrade (download only)
Transaction: upgrade (check only)
Transaction: upgrade (check only)
Transaction: upgrade (check only)
Transaction: upgrade (check only)
Transaction: refresh-md
Transaction: refresh-md
Transaction: refresh-md
Transaction: upgrade (download only)
Transaction: upgrade (download only)
Transaction: upgrade (download only)
Transaction: upgrade (check only)
Transaction: upgrade (check only)
Transaction: upgrade (check only)
Transaction: upgrade (check only)
Transaction: upgrade (check only)
Transaction: refresh-md
Transaction: refresh-md
Transaction: refresh-md
Transaction: refresh-md
Transaction: refresh-md
Transaction: upgrade (download only)
^C%  

i even tried to disable auto updates

% cat /etc/rpm-ostreed.conf 
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# For option meanings, see rpm-ostreed.conf(5).

[Daemon]
AutomaticUpdatePolicy=none
#IdleExitTimeout=60

but i think these are coming from gnome-software-center so probably this setting does not apply

i have to issue rpm-ostree cancel to get it to stop … until it starts again

actually doing rpm-ostree cancel does not help . it start right away again

Even if i disable auto update in gnome software center this keeps happening

i have to systemctl stop rpm-ostreed and restart it to actually make it stop

note that if i manually run rpm-ostree update it works just fine

I came here to this forum trying to find an answer for this exact same question.
Looking at the system journal, it seems like every single Flatpak I have installed is what triggers the rpm-ostree refresh-md process, but they do it one-by-one, instead of a single refresh for the entire gnome-software.

Seems like the original post here has come over a month without response. Is there a different place where this question should be brought up?