Silverblue 38: NVIDIA GeForce 610M: NVIDIA kernel module missing. Falling back to nouveau


I installed Fedora Silverblue (38) on an old Notebook which has an integrated GPU (the info in the settings says “NVD9 / Intel HD Graphics 4000 (IVB GT2)”) as well as an NVIDIA GeForce 610M graphics card. I now want to make use of the graphics card using the nonfree drivers. I followed the installation in the wiki, specifically I run the following commands:

sudo rpm-ostree update --install akmod-nvidia-470xx --install xorg-x11-drv-nvidia-470xx
sudo rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init
sudo systemctl reboot

Those run successfully and I rebooted, but the driver isn’t loaded as the error message “NVIDIA kernel module missing. Falling back to nouveau.” on boot suggests. Is there any way I can fix this? I searched through this forum as well as countless other posts online but I haven’t found many solutions for Silverblue and all of them only mentioned installing the drivers as described above.

Thanks in advance!

I also tried installing the xorg-x11-drv-nvidia and akmod-nvidia drivers which weren’t loaded at all (not even an error message if I remember correctly).

Note 2:
Device security also lists secure-boot as disabled.

I recommend trying out the Universal Blue images to see if this solves your issue:

An additional comment that might be very applicable.
If installed with uefi and secure boot is enabled the nvidia drivers will not load unless signed.

This may be solved by disabling secure boot within the bios or by signing the nvidia modules as noted in the file /usr/share/doc/akmods/README.secureboot then removing and reinstalling the nvidia drivers.

I note that you mentioned that secure boot is already disabled, but it can easily be verified by using the command dmesg | grep -iE 'secure|nvidia|nouveau' which will show the kernel actions during boot including the kernel command line, secure boot status, and driver actions.

I do not work with silverblue, but this command should work with all versions.

I assume this was a typo and should have been akmod-nvidia-470xx.

It also could assist us to see the result of the silverblue (rpm-ostree) equivalent of dnf list installed '*nvidia*'

I rebased onto the nvidia image but this hasn’t resolved my issue. The Info section in the settings app still doesn’t list the GeForce and nvidia-smi still returns “NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running

This lists secureboot as disabled:
secureboot: Secure boot disabled

Yes this was a typo, thanks for correcting!

I would like to provide the rpm-ostree status output, but I don’t know how to switch back from universal blue.

Could you paste the full output of your current rpm-ostree status please? It should show something like If it doesn’t, I recommend trying the rebase command in GitHub - ublue-os/nvidia: Fedora variants with built-in Nvidia drivers.

Also, regarding rebasing back to Fedora Silverblue 38, the command is rpm-ostree rebase fedora:fedora/38/x86_64/silverblue.

Thanks for the rebase command!

rpm-ostree status lists the following:

State: busy
AutomaticUpdates: stage; rpm-ostreed-automatic.timer: no runs since boot
Transaction: refresh-md
  Initiator: client(id:gnome-software dbus:1.110 unit:app-gnome-org.gnome.Software-2077.scope uid:1000)
                   Digest: sha256:67187941e907b77bddbda7c8ce4d54ac44fb532e05e876e201b03f49ef3aa97b
                  Version: 38.20230715.0 (2023-07-15T08:19:47Z)
          LayeredPackages: langpacks-de
                   Digest: sha256:67187941e907b77bddbda7c8ce4d54ac44fb532e05e876e201b03f49ef3aa97b
                  Version: 38.20230715.0 (2023-07-15T08:19:47Z)
          LayeredPackages: langpacks-de