Setting up Quadro P2000 on Fedora 30

Hi there,

I followed the following guide to setup NVidia drivers on Fedora and i’m not sure if it actually worked, running glmark2 actually gives worse scores than when it was on the Intel graphics, the NVidia X Settings dialog doesn’t want to open, it just crashes:

nvidia-installer -v |grep version

nvidia-installer:  version 430.40

uname -a

Linux vlad.localhost 5.2.6-200.fc30.x86_64 #1 SMP Mon Aug 5 13:20:47 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

lspci |grep -E "VGA|3D"

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 3D controller: NVIDIA Corporation GP107GLM [Quadro P2000 Mobile] (rev a1)

Downloaded the official NVidia drivers:

-rwxrwxr-x. 1 vlad vlad 107M Aug 10 11:08 /home/vlad/Downloads/

Installed some additional needed packages:

dnf install kernel-devel kernel-headers gcc make dkms acpid libglvnd-glx libglvnd-opengl libglvnd-devel pkgconfig

Disabled nouveau:

echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
$ cat /etc/modprobe.d/blacklist.conf 
blacklist nouveau

Added rd.driver.blacklist=nouveau to the end of GRUB_CMDLINE_LINUX= in /etc/sysconfig/grub

$ cat /etc/sysconfig/grub
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora_vlad-swap rhgb quiet rd.driver.blacklist=nouveau"

Did a grub update:

grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Removed nouveau driver:

dnf remove xorg-x11-drv-nouveau

Did a “Generate initramfs” (no idea what this is):

## Backup old initramfs nouveau image ##
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
## Create new initramfs image ##
dracut /boot/initramfs-$(uname -r).img $(uname -r)

Rebooted into runlevel 3 where i ran the NVidia installer selecting yes to everything and which installed without problems.

Rebooted back into the graphical interface and installed the following recommended packages:

dnf install vdpauinfo libva-vdpau-driver libva-utils

Running lshw, the output looks a bit suspicious, the Quadro P2000 shows the exact same clockspeed as the Intel graphics:

sudo lshw -numeric -C display
       description: 3D controller
       product: GP107GLM [Quadro P2000 Mobile] [10DE:1CBA]
       vendor: NVIDIA Corporation [10DE]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:ec000000-ecffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:3000(size=128) memory:ed000000-ed07ffff
       description: VGA compatible controller
       product: UHD Graphics 630 (Mobile) [8086:3E9B]
       vendor: Intel Corporation [8086]
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:135 memory:eb000000-ebffffff memory:80000000-8fffffff ioport:4000(size=64) memory:c0000-dffff

glmark2 before the NVidia driver and all of the above:

    glmark2 2017.07
    OpenGL Information
    GL_VENDOR:     Intel Open Source Technology Center
    GL_RENDERER:   Mesa DRI Intel(R) UHD Graphics 630 (Coffeelake 3x8 GT2)
    GL_VERSION:    3.0 Mesa 19.1.3
                                  glmark2 Score: 2289

After the NVidia drivers (it shows VMWare and llvmpipe which looks strange):

    glmark2 2017.07
    OpenGL Information
    GL_VENDOR:     VMware, Inc.
    GL_RENDERER:   llvmpipe (LLVM 8.0, 256 bits)
    GL_VERSION:    3.1 Mesa 19.1.3
Lots of the same errors like this one:
** GLX does not support GLX_EXT_swap_control or GLX_MESA_swap_control!
** Failed to set swap interval. Results may be bounded above by refresh rate.
                                  glmark2 Score: 764 

The score is significantly lower which means something is not setup correctly.

Argh, again this guide dated 2015 from if-not-true-then-false.

As far as I know, the suggested way to install nvidia is by following this guide: Howto/NVIDIA - RPM Fusion

Another good read: Install an NVIDIA GPU on almost any machine - Fedora Magazine

1 Like

this Fedora 30/29/28 nVidia Drivers Install Guide was updated on [August 3, 2019], this guide don’t support your GPU… read carefully before intent something

However @alciregi was right in his suggestion…


Whoops, sorry. :blush:
BTW every time this guide is mentioned, people report some issue.

Did a clean Fedora install to get rid of all the experiments that might potentially break things in the future. Followed the RPM fusion guide and my machine now boots to a black screen with nothing.

sudo dnf update

booted into newly updated kernel

sudo dnf install fedora-workstation-repositories
sudo dnf config-manager --set-enabled rpmfusion-nonfree-nvidia-driver


sudo dnf repository-packages rpmfusion-nonfree-nvidia-driver info

which showed plenty of NVidia output

sudo dnf install xorg-x11-drv-nvidia akmod-nvidia
sudo dnf install xorg-x11-drv-nvidia-cuda
sudo dnf update


Now i’m seeing a black screen

Pressing ‘e’ at grub and removing rhgb and quiet from the params and adding nomodeset=0 followed by ctrl + x then shows lots of chatter in the logs followed by a black screen again.

Going back to the previous kernel, it says missing nvidia drivers, reverting back to nouveau after which i can at least boot back into Fedora.

The black screen problem is supposed to only happen on GDM with Gnome, i’m running KDE with SSDM. I’ve also double checked, secure boot is switched off in the BIOS.

Did a ctrl + alt + F2 during the black screen and did a journalctl -b

Not sure if this provides anything useful:

Grepping through it, i’m seeing lots of these:

Aug 10 17:50:13 vlad.local abrt-notification[1376]: System encountered a non-fatal error in acr_r352_bootstrap()
Aug 10 17:50:13 vlad.local kernel: iwlwifi 0000:3b:00.0: Microcode SW error detected. Restarting 0x0.
Aug 10 17:50:13 vlad.local kernel: iwlwifi 0000:3b:00.0: Firmware error during reconfiguration - reprobe!
Aug 10 17:50:13 vlad.local kernel: iwlwifi 0000:3b:00.0: FW error in SYNC CMD GEO_TX_POWER_LIMIT
Aug 10 17:50:13 vlad.local NetworkManager[1269]: <warn>  [1565452213.3985] platform-linux: do-change-link[3]: failure changing link: failure 5 (Input/output error)

and these:

Aug 10 17:50:12 vlad.local kernel: iwlwifi 0000:3b:00.0: 0x2B6AAD46 | FSEQ_ERROR_CODE
Aug 10 17:50:13 vlad.local kernel: iwlwifi 0000:3b:00.0: 0x2B6AAD46 | FSEQ_ERROR_CODE
Aug 10 17:50:14 vlad.local kernel: iwlwifi 0000:3b:00.0: 0x2B6AAD46 | FSEQ_ERROR_CODE
Aug 10 17:50:14 vlad.local kernel: iwlwifi 0000:3b:00.0: 0x2B6AAD46 | FSEQ_ERROR_CODE
Aug 10 17:50:15 vlad.local kernel: iwlwifi 0000:3b:00.0: 0x2B6AAD46 | FSEQ_ERROR_CODE
Aug 10 17:50:15 vlad.local kernel: iwlwifi 0000:3b:00.0: 0x2B6AAD46 | FSEQ_ERROR_CODE
Aug 10 17:50:16 vlad.local kernel: iwlwifi 0000:3b:00.0: 0x2B6AAD46 | FSEQ_ERROR_CODE

Downgrading the wifi driver doesn’t seem to sort out the black screen.

Keep in mind that with akmod, there is a time delay between when you install the rpm and the kernel module is built locally and ready to actually use. I believe rpmfusion has things packaged so nicely now that it will do so before you reboot, if given time but will failover to building it post-boot if necessary. In the latter case, you will see a black screen because it’s simply not ready. Running top should easily reveal the activity and there’s likely logs showing effort too. But yeah on the black screen, it’s completely normal for a reasonable period. On my hardware, this may mean a few minutes.