Setting up hibernation with secure boot and disk encryption

,

EDIT: Read my first reply. I solved the following problem already but need help setting up hibernation.

Yesterday I installed Fedora KDE on my new Laptop (Dell Inspiron 14 Plus, Alder Lake based), with secure boot enabled and LUKS2 disk encryption, and no other operating systems installed. Everything worked fine at first.
But since Alder Lake doesn’t support S3 sleep (AFAIK) and S2idle drains the battery very quickly, I wanted to set up hibernation with a swap file.
But now, after adding the resume parameter to the kernel parameters and running grub2-mkconfig, when I reboot, GRUB only shows UEFI Firmware setup when I start my computer, with no option to boot Fedora.
The grub.cfg file exists and looks correct to me, and in fact I can manually boot my system from the GRUB shell by specifying the exact same kernel parameters from that file, but that is of course very tedious.
I have already tried undoing my steps by removing the resume parameters and regenerating grub.cfg once more, but that didn’t bring back my boot options. Neither did disabling secure boot.

Any help in fixing GRUB as well as tips on setting up hibernation with secure boot (preferably without compiling a custom kernel) would be greatly appreciated

Wow, I have that weird habit of figuring out the solution to my problems JUST after asking online.
I made the mistake of letting grub2-mkconfig overwrite /boot/efi/EFI/fedora/grub.cfg rather than /boot/grub2/grub.cfg. I managed to restore it to how it should be now, so I can boot normally again.

I would still appreciate help with hibernation. I would really prefer not to disable secure boot, but I read that hibernation won’t work with secure boot unless the kernel was compiled with some specific option that allows it, which the default Fedora kernel apparently isn’t / wasn’t. Does that still apply? I’d rather not have to regularly recompile my own kernel if I can avoid it.