Screen tearing, poor frame rate on KDE 6.1.1 | Nvidia | F40

Hello there,
I’m new to the Gnu/Linux world, only a few months into it. I usually try to find solutions by myself, but this time I’m stuck. :wink:

I thought the latest driver fixed the issue with Wayland and Nvidia. But, although the system is “stable”, everything feels jerky. The cursor stutter, as the windows when I move or resize them. And when I open the app launcher, it feels like I am running at 12 fps…

So I stick to x11, where everything is smooth!

I’ve tested other kernels, made a fresh new install, update everything, unplugged one of my two monitors, with no success so far! :cry:

And of course, in games, it’s the same :

On X11 :


Everything is smooth.

On wayland :


Although the fps are higher, it stutters a lot (the Frametime ranges from 2.1 to 13.6)

Those are pictures from Diablo IV running on Lutris, but I have the same issue with steam games. (none are flatpacks)

I don’t have enough knowledge to go further alone. :slight_smile:
Any idea how I can fix this ?

Infos :
inxi -Fzxx

System:
  Kernel: 6.9.8-cb1.0.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: KDE Plasma v: 6.1.1 tk: Qt v: N/A wm: kwin_x11 dm: SDDM
    Distro: Fedora Linux 40 (KDE Plasma)
Machine:
  Type: Desktop System: Gigabyte product: X570 AORUS ELITE v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: X570 AORUS ELITE serial: <superuser required>
    UEFI: American Megatrends LLC. v: F39 date: 03/22/2024
Battery:
  ID-1: hidpp_battery_0 charge: 47% condition: N/A volts: 3.8 min: N/A
    model: Logitech G703 LIGHTSPEED Wireless Gaming Mouse w/ HERO
    serial: <filter> status: discharging
CPU:
  Info: 8-core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3+
    rev: 0 cache: L1: 512 KiB L2: 4 MiB L3: 32 MiB
  Speed (MHz): avg: 1527 high: 3769 min/max: 550/4851 boost: enabled cores:
    1: 550 2: 3600 3: 550 4: 3599 5: 550 6: 550 7: 3655 8: 550 9: 550 10: 3766
    11: 550 12: 550 13: 3769 14: 550 15: 550 16: 550 bogomips: 121601
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3
Graphics:
  Device-1: NVIDIA GA102 [GeForce RTX 3080 Ti] driver: nvidia v: 555.58.02
    arch: Ampere pcie: speed: 5 GT/s lanes: 16 ports: active: none
    off: DP-2,DP-3 empty: DP-1,HDMI-A-1 bus-ID: 08:00.0 chip-ID: 10de:2208
  Device-2: Oculus VR Rift CV1 Sensor driver: uvcvideo type: USB rev: 3.0
    speed: 5 Gb/s lanes: 1 bus-ID: 6-3:3 chip-ID: 2833:0211
  Device-3: Oculus VR Rift CV1 Sensor driver: uvcvideo type: USB rev: 3.0
    speed: 5 Gb/s lanes: 1 bus-ID: 6-4:4 chip-ID: 2833:0211
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 108
  Monitor-1: DP-2 note: disabled pos: left model: VG27A res: 2560x1440
    dpi: 109 diag: 685mm (27")
  Monitor-2: DP-3 mapped: DP-4 note: disabled pos: primary,right
    model: VG27A res: 2560x1440 dpi: 109 diag: 685mm (27")
  API: EGL v: 1.5 platforms: device: 0 drv: nvidia device: 2 drv: swrast
    gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 555.58.02
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2
  API: Vulkan v: 1.3.283 surfaces: xcb,xlib device: 0 type: discrete-gpu
    driver: N/A device-ID: 10de:2208 device: 1 type: cpu driver: N/A
    device-ID: 10005:0000
Audio:
  Device-1: NVIDIA GA102 High Definition Audio driver: snd_hda_intel v: kernel
    pcie: speed: 16 GT/s lanes: 16 bus-ID: 08:00.1 chip-ID: 10de:1aef
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: speed: 16 GT/s lanes: 16
    bus-ID: 0a:00.4 chip-ID: 1022:1487
  API: ALSA v: k6.9.8-cb1.0.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 04:00.0 chip-ID: 8086:1539
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 1-3.1:4
    chip-ID: 0a12:0001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: <filter> bt-v: 4.0 lmp-v: 6
Drives:
  Local Storage: total: 3.19 TiB used: 607.31 GiB (18.6%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 980 PRO 1TB size: 931.51 GiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 45.9 C
  ID-2: /dev/sda vendor: Crucial model: CT512MX100SSD1 size: 476.94 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-3: /dev/sdb vendor: Samsung model: Portable SSD T5 size: 1.82 TiB
    type: USB rev: 3.1 spd: 10 Gb/s lanes: 1 serial: <filter>
Partition:
  ID-1: / size: 475.35 GiB used: 42.11 GiB (8.9%) fs: btrfs dev: /dev/sda3
  ID-2: /boot size: 973.4 MiB used: 532.2 MiB (54.7%) fs: ext4
    dev: /dev/sda2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/sda1
  ID-4: /home size: 475.35 GiB used: 42.11 GiB (8.9%) fs: btrfs
    dev: /dev/sda3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 54.0 C mobo: 34.0 C gpu: nvidia temp: 44 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 35%
Info:
  Memory: total: 32 GiB available: 31.27 GiB used: 4.32 GiB (13.8%)
  Processes: 423 Power: uptime: 26m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 13 Compilers: gcc: 14.1.1 Shell: Bash
    v: 5.2.26 running-in: konsole inxi: 3.3.34

I don’t use KDE, and but have a Laptop with similar Hardware family, I don’t experience these issues on Gnome. I have seen a lot of KDE user with issues with Nvidia Graphics, so maybe the stutter/frame dips and tearing will go away with time.

I don’t know if KDE has VRR enabled or if you can enable it. . . it might help. Others will chime in.

1 Like

I think I have VRR activated :
image

I will test gnome if I don’t find any workaround.
Is there any issue having GNOME and KDE installed together?

I don’t recommend it to be honest. Issues will arise, Some more seasoned Linux users attempt it by isolating 2 users on the machine. 1 exclusively for each.

I think KDE has some experimental features for VRR and the like so hang in there some others will chime in.

That’s looks to be for your X11 session. which comes back to your comment on how smooth it feels.

1 Like

If I can’t fix it on KDE, I will make a fresh installation with GNOME, I’m starting to be good at reinstalling. :slight_smile:

My bad, yes, it’s on the X11 session. :wink:
I switch a lot between the two sessions.

You are right, the VRR is not enabled on Wayland. So now I can search in a new direction to fix this.

https://www.reddit.com/r/kde/comments/wyr9ef/vrr_options_on_wayland/

1 Like

Thank you for the link.

I looked this option, I was on “Automatic” so I tried “Never”, no changes, and “Always” no change either.
The frametimes stutters were the same, as if this option wasn’t working at all… :confused:

I tried the solution found here :

Disable GSP

It worked perfectly… for 10 sec, then my system crashed :stuck_out_tongue:

1 Like

Now I have to ask,

  • what applications or games did you test.
  • What tool did you test with.
  • Are you sure you have the Nvidia driver installed properly?
  • In Gnome we have “Power Management” can you check KDE to see if it has a Power Mnagement setting you could change to Performance or High?
  • Please post dnf list installed \*nvidia\* for us to see
1 Like

Even the DE stutters, but I have tested several games on lutris and steam :
Diablo4 (battlenet on lutris)
Overwatch2 (steam)
Last Epoch (steam)
Death Stranding (EGS on lutris)
and many more.

Mangohud to reveal the frametimes. But its noticable to the naked eye everywhere else on the DE.

I hope so… :stuck_out_tongue:
As i have done at least 2 fresh install, and followed the FAQ of RPM fusion, i think it s ok.

It’s a desktop, I don’t see any setting alike.

akmod-nvidia.x86_64                                                                      3:555.58.02-1.fc40                                                @System                   
kmod-nvidia-6.9.7-200.fc40.x86_64.x86_64                                                 3:555.58.02-1.fc40                                                @@commandline             
kmod-nvidia-6.9.7-cb1.0.fc40.x86_64.x86_64                                               3:555.58.02-1.fc40                                                @@commandline             
kmod-nvidia-6.9.8-cb1.0.fc40.x86_64.x86_64                                               3:555.58.02-1.fc40                                                @@commandline             
libva-nvidia-driver.x86_64                                                               0.0.12-2.fc40                                                     @updates                  
nvidia-gpu-firmware.noarch                                                               20240610-1.fc40                                                   @System                   
nvidia-modprobe.x86_64                                                                   3:555.58.02-1.fc40                                                @System                   
nvidia-persistenced.x86_64                                                               3:555.58.02-1.fc40                                                @rpmfusion-nonfree-updates
nvidia-settings.x86_64                                                                   3:555.58.02-1.fc40                                                @System                   
xorg-x11-drv-nvidia.x86_64                                                               3:555.58.02-1.fc40                                                @System                   
xorg-x11-drv-nvidia-cuda.x86_64                                                          3:555.58.02-1.fc40                                                @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.i686                                                       3:555.58.02-1.fc40                                                @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-cuda-libs.x86_64                                                     3:555.58.02-1.fc40                                                @System                   
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                       3:555.58.02-1.fc40                                                @System                   
xorg-x11-drv-nvidia-libs.i686                                                            3:555.58.02-1.fc40                                                @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                                          3:555.58.02-1.fc40                                                @System                   
xorg-x11-drv-nvidia-power.x86_64                                                         3:555.58.02-1.fc40                                                @System

:thinking: What is that? Are you using a different kernel outside of the standard Fedora kernels?

1 Like

I had the same issue with the Standard Fedora Kernel, so I installed the Cachy OS Kernel for fedora to see if it fixed the issue (obviously it did not).

I’m not sure what this kernel offers, but it’s clearly not helping in performance. Could you please boot into the Standard Fedora kernel as we continue to test this. There’s no way for us to troubleshoot issues with kernels outside of what we use.

1 Like

Sure.

I’ll do it and give the “Disable GSP” solution another try with fedora’s kernel.
I will keep you informed of the results

1 Like

@hamrheadcorvette Thanks a lot for the time and effort. :slight_smile:

It seems to be working. The issue was indeed the GSP!

But for some reason it crashes with the cachyos kernel, reverting to the standard, unistalling cachyos and applying the GSP solution fixed the issue.

etocsi@Fedora40:~$ nvidia-smi -q | grep GSP
    GSP Firmware Version                  : N/A

What have I learned :
Before applying a “kernel” tweek to fix an issue, it’s best practice to roll back to a stable “vanila” kernel :slight_smile:
Because the custom kernel may not be the cause of the issue, but can prevent the solution to work.

1 Like

:fedora: :+1:t5:

Proton/Experimental/GE/tkg/DXVK/VK3D have all done their best to get the software stack to where it needs to be to perform in games in many instances better than Windows.

I have a pet peeve with custom kernels because I don’t think it solves anything. :fire: Hot Take :fire:


If any of this helped, please mark it as a solution. Thanks ! :cowboy_hat_face:

1 Like

I’ve learned my lesson :slight_smile:

A custom kernel may solve a specific issue for a specific machine with a specific hardware and software config but as noted, is seldom a panacea for everyone. Better that the suggested patches in that custom kernel be passed upstream for testing and verification to be included in the mainstream kernels.

2 Likes

So this issue is specific to KDE :thinking: interesting. . .

NOTED :exclamation:

1 Like

The tearing could be because the fps is too high and faster then the display supports.

I always turn on vsync in all games to prevent tearing.