Screen selecting fails sometimes while sharing screen on Wayland on Fedora KDE 40

As the screen-sharing option is absent on the Skype official app or the Flatpak version, I mostly use the Microsoft Edge browser to share the screen. However, while attempting to select a screen, the process fails. For a better understanding, look at the following pictures.

You can see that despite selecting the external Xiaomi monitor as the source, I cannot proceed since the ‘ok’ button is disabled.

I am experiencing the same behavior when I try to select the laptop screen as the source.

I am getting the same experience with any other web applications; such as Google Meet, and Discord. And the behavior is the same on any browser.

After repetitive attempts, I become successful in selecting the screen source, but I find this quite painstaking.

Please note that I have only the Nouveau open-source driver installed for my NVIDIA GPU.

Is there any way to troubleshoot this issue?

Most likely you need the nvidia driver installed from rpmfusion. You did not tell us which nvidia GPU is installed, but newer ones are not fully supported by nouveau and none are capable of hardware acceleration graphics with nouveau.

The NVIDIA GPU is GeForce GTX 1650 Mobile / Max-Q. And, previously, I did install the proprietary drivers from RPM Fusion but the result was the same. I got to know from one site(I cannot recall it now) that the proprietary drivers sometimes create issues in screen-sharing. That’s why I removed them 2 to 3 weeks ago. Sadly, I did notice any improvement on this.

That is the same gpu in my laptop. I don’t use screen sharing with the browsers regularly, but have done so using zoom and it worked the last time I tried it. I use the chrome browser.

I also normally use X11 so have little experience with how it would work with wayland.

Do you use an external monitor? I have tried using X11 but the thing is after some time, the display rendering and key-stroke event handling become slow on the external monitor on X11. I have seen it on IntelliJ. I don’t get the same experience while I’m on a Wayland session.

Yes, but not exclusively. I use mirroring since the screen on the laptop is hard to read with its size and resolution. Larger screen → easier to read.

Do you use any JetBrains IDE? After some time, the key-stroke event handling becomes slow on some apps(especially on the IDEs of JetBrains) on my external Monitor, given that I use the monitor exclusively.