Screen/output detection after update

G’day. Have been using Sway (Wayland) for a few weeks now, having used bspwm (X11) for years. Really enjoying it. I have a laptop that was LVDS-1 and external monitor connect to display port that was DP-2.

Just did an update, and noticed kernel updated to 6.3.4 so rebooted. Now the external monitor does not appear to be detected at all. Output of xrandr --query indicates that the laptop screen is now being named XWAYLAND0, but the external monitor does not appear at all.

I also tried running Gnome (Wayland) and bspwm (X11) on this same machine and the external display is not connecting on any of them. Initially I thought it was just a Sway issue, then a Wayland issue, but the fact that bspwm isn’t working either leads me to think it’s a kernel issue? But I rebooted and reverted back to a previous kernel 6.2.14 and it still didn’t work although I’m sure that kernel was working correctly previously.

I didn’t take in all of the updates that were done, but did notice mesa in there as well.

Also, oddly, the background image I had specified as wallpaper is no longer displaying, just the default Sway background - but I suspect this is a symptom of the output issue above. Just thought I’d mention it.

Any tips or ideas?

Still not sure what’s going on. I’ve booted from a live USB and both screens/monitors worked on that, so it’s clearly something going on with Fedora and it not detecting the display port external monitor. Any ideas?

I just installed xorg-x11-drv-nvidia-390xx and akmod-nvidia-390xx
Now sway no longer appears as an option in gdm, but fortunately bspwm does and I can successfully boot into bspwm with both screens working. Obviously this is using X11 not Wayland.

Still keen to get Wayland/Sway back if anyone has any tips.