Screen flashes after installation

I’m trying to install Linux on a Dell Netbook for ages. Since I’m a Fedora User and Ambassador I’ve tried Fedora first. While the live image works fine, after installation I can’t boot: the screen starts flashing and it just stays like that without ever completing the booting sequence.

I’ve uploaded a video here so you can understand better what’s happening.

The Netbook is a Dell Inspiron 1090 and it used to work fine with Windows.

Tried every spin available with no success, a lot of distros also with no success. Can anyone please help?

That some sort of problem with plymouth. First thing I would do is to update all packages (sudo dnf update), then restart the computer. (your kernel is pretty old)

What does

systemctl status plymouth-quit-service


@florian as far as I can understand, the boot process never completes.

@galvao, the screen is not simply flashing. There is something written. It is the boot process, isn’t it? The textual boot is alternated with the graphical (plymouth as said by @florian) one giving the sense of flashing.
Some service is in loop or the like. Are you able to see what’s written on screen?
You could also edit the grub entry to disable the graphical boot: keep SHIFT pressed during boot early stages, when the grub menu appears hit e, then remove rhgb and quiet from the linux line, finally press CTRL+x

As @alciregi pointed out, the machine doesn’t complete boot ing. I wonder if I could try to boot to a text only screen though.

It could be useful to know what is continuously printed on the screen.

I was just able to get a decent screenshot (below). Removing rhgb and quiet didn’t solved the issue though.

Sorry, :sweat_smile: indeed it wasn’t supposed that removing these lines solved your issue.
The scope of removing rhgb and quiet was to avoid graphical boot to start, trying to stop the screen from flashing.

1 Like

Ah, yes, I’ve got that part. Still, what I’ve meant is that the screen kept flashing even after removing those and proceeding.

Any idea where to go from here? @alciregi @florian

After a lengthy discussion on the fedora channel at freenode (thank you so much, temple48!) the solution was finally found: disabling Plymouth altogether, meaning adding:

nouveau.modeset=0 rd.plymouth=0 plumouth.enable=0

to grub.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.