I have lost plymouth after installing NVIDIA proprietary drivers

Since I installed NVIDIA proprietary drivers I have lost plymouth.

Following this topic, I have added GRUB_CMDLINE_LINUX="rhgb quiet" to /etc/default/grub:

$ grep "rhgb quiet" /etc/default/grub

and then I run:

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

and rebooted.

But still no plymouth :frowning:

This is normal and there’s nothing you can do about it. Plymouth simply doesn’t work with the proprietary nVidia drivers.

AFAIK plymouth works. I have nvidia graphics, have upgraded repeatedly and with every version of fedora the plymouth boot graphics has worked. Don’t understand why you would say it does not.

@johnnyjuki can you tell us what you see that makes you say plymouth is not working?
Where did you get the nvidia drivers? rpmfusion or somewhere else?

I used nVidia graphics with Fedora and the drivers from rpmfusion for about ten years and never had access to plymouth. It’s always been common knowledge that the two don’t work together. If you have it working, are you using nouveau, or if not, what have you done differently? It’s possible, of course, that the two work together now, but if so, I’ve never heard of it until now.

The graphical login screen on fedora is plymouth AFAIK and it has always worked for me. If someone in the know can tell me differently then I would appreciate the education.

What exactly are you not getting access to?

I found this though.

The only thing it shows that is not already part of installing the nvidia drivers from rpmfusion and the changes that makes is this

4.4 Check available Plymouth themes
## Fedora 35/34/33/32/31 ##
dnf search plymouth-theme
========================= Name Matched: plymouth-theme =========================
plymouth-theme-solar.x86_64 : Plymouth "Solar" theme
plymouth-theme-charge.x86_64 : Plymouth "Charge" plugin
plymouth-theme-script.x86_64 : Plymouth "Script" plugin
plymouth-theme-breeze.x86_64 : Breeze theme for Plymouth
plymouth-theme-spinner.x86_64 : Plymouth "Spinner" theme
plymouth-theme-fade-in.x86_64 : Plymouth "Fade-In" theme
plymouth-theme-spinner.x86_64 : Plymouth "Spinner" theme
plymouth-theme-hot-dog.noarch : Plymouth Happy Hot Dog Theme
plymouth-theme-spinfinity.x86_64 : Plymouth "Spinfinity" theme
4.5 Install Plymouth and some Plymouth theme, example spinfinity
## Fedora 35/34/33/32/31 ##
dnf install plymouth-theme-spinfinity

and I just checked mine and see

# dnf list installed plymouth*
Installed Packages
plymouth.x86_64                                               0.9.5-2.20210331git1ea1020.fc34                                @fedora
plymouth-core-libs.x86_64                                     0.9.5-2.20210331git1ea1020.fc34                                @fedora
plymouth-graphics-libs.x86_64                                 0.9.5-2.20210331git1ea1020.fc34                                @fedora
plymouth-plugin-label.x86_64                                  0.9.5-2.20210331git1ea1020.fc34                                @fedora
plymouth-plugin-two-step.x86_64                               0.9.5-2.20210331git1ea1020.fc34                                @fedora
plymouth-scripts.x86_64                                       0.9.5-2.20210331git1ea1020.fc34                                @fedora
plymouth-system-theme.x86_64                                  0.9.5-2.20210331git1ea1020.fc34                                @fedora
plymouth-theme-spinner.x86_64                                 0.9.5-2.20210331git1ea1020.fc34                                @fedora

so it is possible yours is different but plymouth works for me with nothing special done.

I do know there are differences between installing nvidia directly from nvidia and installing from the rpmfusion repo so that may affect what you are seeing.

Ah. Open mouth, exchange feet. What I was thinking of was the graphic display during boot that covers up the boot messages. When I was (past tense) using nVidia graphics, all I got was a progress bar, and that was what I was referring to. Thanx for the correction.