Rtl8821ce driver not working

Hi, there i am new to Fedora. I am currently using Fedora 34. I am not able to connect to my Phone using Wi-fi infact the Wi-Fi option is not even available. For the past few weeks I tried many ways. Tried to install the driver from repo of tomaspinho. Then an anoher method by deleting all tge old kernels and installing it . But it’s still not working.
Pls Help!!
Thanks in Advance :blush:

Welcome to ask Fedora !

Did you remove the old ones?
Have a look here:



First i found the version number
Then i ran this code
sudo dkms remove -m rtl8821ce -v ??? -k 5.13.12-200.fc34.x86_64
By replacing the ??? with my version number.
Then used modprobe rtw88_8821ce
But nothing worked

1 Like

With uname -a you get your kernel nr and you have to replace 5.13.12 with your version number, did you try that?

For past 2 days I tried this and many other commands and finally ended up breaking my Bluetooth too.
Now neither BT or the WiFi is working :grimacing:

show command output

#nmcli radio all
#rfkill list all

After removing the rtl8821ce and again reinstalling it the Bluetooth is working now.
But still WiFi is not available

silly question: Have you done a cold restart (shutdown and start)?

Yes many times :sweat_smile: