Renaming LVM2 volume group in Cockpit makes system unbootable

Despite having given the machine a host name in the Fedora Server edition installer, the LVM2 volume group still used the network provided name. So I renamed the group post-install, and the system became unbootable.

I found the reason to be boot entries (I use systemd-boot). The volume name in is still the old one, so I modified it manually and the system booted.

The problem is, after a kernel upgrade, the new boot entry generated still uses the old name.
Are there more config files that I need to change to fix that?

p.s. Also I think a warning and/or an instruction in the Cockpit would be nice.

Did you also fix it in /etc/kernel/cmdline?

1 Like

The entry file has a comment

# File created by /usr/lib/kernel/install.d/90-loaderentry.install (systemd 254.7-1.fc39)

The content of 90-loaderentry.install includes

if [ -n "$KERNEL_INSTALL_CONF_ROOT" ]; then
    if [ -f "$KERNEL_INSTALL_CONF_ROOT/cmdline" ]; then
        BOOT_OPTIONS="$(tr -s "$IFS" ' ' <"$KERNEL_INSTALL_CONF_ROOT/cmdline")"
elif [ -f /etc/kernel/cmdline ]; then
    BOOT_OPTIONS="$(tr -s "$IFS" ' ' </etc/kernel/cmdline)"
elif [ -f /usr/lib/kernel/cmdline ]; then
    BOOT_OPTIONS="$(tr -s "$IFS" ' ' </usr/lib/kernel/cmdline)"
    BOOT_OPTIONS="$(tr -s "$IFS" '\n' </proc/cmdline | grep -ve '^BOOT_IMAGE=' -e '^initrd=' | tr '\n' ' ')"


    echo "options    $BOOT_OPTIONS"

Thus yes, change the cmdline.