Removing recent kernel upate

I know I am asking a lot of questions recently.
Having said this my Gaming Desktop has been broken for a better part of the last 2-3 weeks, and instead of giving up I want to learn how to manage my Fedora system properly.
It was working fine on F39 but the upgrade to F40 broke something. Now I am having a really difficult time getting it to the stability I had it before.
I have been using some sort of RHEL derivative here and there for over 14 years, but I took the plunge to go full in on Linux 3 years ago and am even migrating my Gaming Desktop from Windows to Linux/Fedora.
I run Fedora on my XPS work laptop without major issues for the last 3 years, and had my Gaming Desktop running great for a few months on F39 until said update.
I have tried other distros, Ubuntu, Arch, and Fedora Gnome is the one that suits my needs the best, and I like the most.
I have reinstalled F40 several times now, trying different approaches, etc. Also worthy a mention I do use Secure Boot as I am still dual booting with Windows 11, for now.

Ok so the ask, I think a kernel update today broke my system, it’s doing funny things.
My thought is; due to me not properly signing dkms certs in the previous kernel prior to update some packages got messed up and the system is doing funky things.
I have signed the dkms certs since in the previous kernel and reinstalled the new kernel, but it’s still wonky.
I would like to remove the new kernel update completely, and re-download the updates and try again.

How do I permanently remove this update from the system?

Added f40 and removed f39

See How to reset kernel to default? - #3 by boxjellyfish