Removing Nvidia driver and reverting to Nouveau fails to load

Lately I find out that the ddcutil and ddccontrol doesn’t work, and as much as I tried to fix them … no luck. So I decided to remove Nvidia drivers, but somehow the Nouveau don’t load. I tried remove possible “blacklist” options I could find online [for example the files automatically created by Nvidia installer in /etc/modprobe.d/], but still lsmod | grep nouveau returns nothing.

What should I do?

I’m not sure about what this stuff means, but could this be the problem?

$ sudo modprobe -v nouveau
insmod /lib/modules/6.3.8-200.fc38.x86_64/kernel/drivers/media/cec/core/cec.ko.xz 
insmod /lib/modules/6.3.8-200.fc38.x86_64/kernel/drivers/gpu/drm/display/drm_display_helper.ko.xz 
insmod /lib/modules/6.3.8-200.fc38.x86_64/kernel/drivers/gpu/drm/ttm/ttm.ko.xz 
insmod /lib/modules/6.3.8-200.fc38.x86_64/kernel/drivers/gpu/drm/drm_ttm_helper.ko.xz 
insmod /lib/modules/6.3.8-200.fc38.x86_64/kernel/drivers/i2c/algos/i2c-algo-bit.ko.xz 
insmod /lib/modules/6.3.8-200.fc38.x86_64/kernel/drivers/gpu/drm/nouveau/nouveau.ko.xz modeset=0 modeset=0

The last line those values being 0 instead of 1?

Reinstalling Fedora to the latest edition 38 did the trick. :sweat_smile:Awesome improvement to graphic stuff by default! Well done devs & co.