Computer fails to boot with nouveau driver blacklisted. Combination of igpu and dgpu laptop

My computer has both an iGPU and a NVIDIA 2060 dGPU combination. A couple months ago, my computer failed to boot and I’ve been having this issue ever since. I think this was at some point when the NVIDIA driver was updated, worked before, updated, and didn’t boot after. The NVIDIA driver was installed with the RPM-fusion repo through the terminal.

My computer continues to halt at “triggering uevents.”

I have asked on another forum and was shown the boot commands of rd.driver.blacklist and drm.modeset, with someone saying that they had an issue with the drm modeset command line entry and it needed to be removed. I was also asked if I had multiple displays, which I do, I have two, one over HDMI and the other over DP.

I tried:
Each of the HDMI and DP monitor as solo display - hang on boot.
removing the drm modeset parameter - hang on boot.
Remove the rd.driver.blacklist=nouveau - boots fine.
Tried multiple distributions (other than Fedora). - Always hangs on “triggering uevents” ONLY after NVIDIA driver is installed.

Question 1) If I remove the rd.driver.blacklist for the nouveau driver, will it not allow the NVIDIA driver to function?
Question 2) Is there anyway to fix this? Is there an issue with the pass through for the dGPU and not working without the nouveau driver being available?
Question 3) Is this just an NVIDIA issue?

I appreciate any help on this issue.

We do not know what you have installed as drivers, nor what is active. Since you have noted that the issue seems to be related to nvidia/nouveau, please post the following.
dnf list installed *nvidia*,
dmesg | grep -iE 'secure|nouveau|nvidia',
lsmod | grep -iE 'nouveau|nvidia',
and finally inxi -Fzxx

Those details should give us enough info to make intelligent suggestions on how to resolve the problems.

Hi Jeff, Thank you very much for your response. I am pretty new to linux, so I am not the most savvy. At the moment, I removed the “nouveau” driver from blacklist in grub so I can load into fedora. I can give you those things though. Please see below.

akmod-nvidia.x86_64                      3:520.56.06-1.fc36 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.0.5-200.fc36.x86_64.x86_64 3:520.56.06-1.fc36 @@commandline       
kmod-nvidia-6.0.7-200.fc36.x86_64.x86_64 3:520.56.06-1.fc36 @@commandline       
nvidia-gpu-firmware.noarch               20221012-141.fc36  @updates            
nvidia-settings.x86_64                   3:520.56.06-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64               3:520.56.06-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64     3:520.56.06-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64       3:520.56.06-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.i686            3:520.56.06-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64          3:520.56.06-1.fc36 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64         3:520.56.06-1.fc36 @rpmfusion-nonfree-nvidia-driver
[    0.000000] Command line: BOOT_IMAGE=(hd0,gpt2)/boot/vmlinuz-6.0.7-200.fc36.x86_64 root=UUID=db15927d-4ce0-4801-9c23-6dfc120be8b5 ro rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=UUID=e3b19f3d-64f6-4b15-8af9-dd17a9226be3 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[    0.000000] secureboot: Secure boot disabled
[    0.014402] secureboot: Secure boot disabled
[    0.083373] Kernel command line: BOOT_IMAGE=(hd0,gpt2)/boot/vmlinuz-6.0.7-200.fc36.x86_64 root=UUID=db15927d-4ce0-4801-9c23-6dfc120be8b5 ro rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=UUID=e3b19f3d-64f6-4b15-8af9-dd17a9226be3 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
[    5.242083] nvidia-gpu 0000:01:00.3: enabling device (0000 -> 0002)
[    5.485354] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:06.0/0000:01:00.1/sound/card1/input13
[    5.485463] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:06.0/0000:01:00.1/sound/card1/input14
[    5.485550] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:06.0/0000:01:00.1/sound/card1/input15
[    5.485583] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:06.0/0000:01:00.1/sound/card1/input16
[    5.485628] input: HDA NVidia HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:06.0/0000:01:00.1/sound/card1/input17
[    6.120918] Bluetooth: hci0: Secure boot is enabled
[    6.686409] nvidia: loading out-of-tree module taints kernel.
[    6.686419] nvidia: module license 'NVIDIA' taints kernel.
[    6.692488] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    6.735708] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000
[    6.737595] nvidia-nvlink: Nvlink Core is being initialized, major device number 509
[    6.738337] nvidia 0000:01:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[    6.785736] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  520.56.06  Thu Oct  6 21:38:55 UTC 2022
[    6.865308] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.
[    6.917562] nvidia-uvm: Loaded the UVM driver, major device number 507.
[    6.953464] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  520.56.06  Thu Oct  6 21:22:53 UTC 2022
[    6.957150] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    7.938966] [drm] Initialized nvidia-drm 0.0.0 20160202 for 0000:01:00.0 on minor 1
nvidia_drm             73728  15
nvidia_modeset       1187840  3 nvidia_drm
nvidia_uvm           2854912  0
nvidia              55250944  270 nvidia_uvm,nvidia_modeset
i2c_nvidia_gpu         16384  0
  Kernel: 6.0.7-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-36.fc36 Desktop: GNOME v: 42.6 tk: GTK v: 3.24.34 wm: gnome-shell
    dm: GDM Distro: Fedora release 36 (Thirty Six)
  Type: Mini-pc System: Intel Client Systems product: NUC11PHi7 v: M26149-404
    serial: <superuser required> Chassis: Intel Corporation type: 35 v: 2.0
    serial: <superuser required>
  Mobo: Intel model: NUC11PHBi7 v: M26151-403 serial: <superuser required>
    UEFI: Intel v: PHTGL579.0063.2021.0707.1057 date: 07/07/2021
  Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 12 MiB
  Speed (MHz): avg: 2515 high: 2800 min/max: 400/4700 cores: 1: 2800
    2: 2800 3: 2800 4: 2800 5: 2376 6: 2800 7: 950 8: 2800 bogomips: 44851
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
    arch: Gen-12.1 ports: active: none empty: DP-1, DP-2, DP-3, DP-4
    bus-ID: 00:02.0 chip-ID: 8086:9a49
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Intel
    driver: nvidia v: 520.56.06 arch: Turing pcie: speed: 8 GT/s lanes: 4
    ports: active: none off: DP-5,HDMI-A-1 empty: none bus-ID: 01:00.0
    chip-ID: 10de:1f15
  Display: wayland server: v: 1.20.14 with: Xwayland v: 22.1.5
    compositor: gnome-shell driver: gpu: nvidia,nvidia-nvswitch display-ID: 0
  Monitor-1: DP-5 model: MSI MAG273R res: 1920x1080 dpi: 81
    diag: 685mm (27")
  Monitor-2: HDMI-A-1 model: Asus VH236H res: 1920x1080 dpi: 94
    diag: 598mm (23.5")
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA
    520.56.06 direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel
    v: kernel bus-ID: 3-3:4 chip-ID: 18d1:5033
  Device-2: NVIDIA TU106 High Definition Audio vendor: Intel
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 4
    bus-ID: 01:00.1 chip-ID: 10de:10f9
  Device-3: Google Pixel earbuds type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.7-200.fc36.x86_64 running: yes
  Sound Server-1: PulseAudio v: 15.0 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Intel Ethernet I225-LM driver: igc v: kernel pcie:
    speed: 5 GT/s lanes: 1 port: N/A bus-ID: 59:00.0 chip-ID: 8086:15f2
  IF: enp89s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:8 chip-ID: 8087:0026
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 1.36 TiB used: 31.82 GiB (2.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 31.9 C
  ID-2: /dev/nvme1n1 vendor: Smart Modular Tech. model: SHGP31-500GM-2
    size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 36.9 C
  ID-1: / size: 57.37 GiB used: 8.92 GiB (15.6%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 998 MiB used: 14 MiB (1.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 851.41 GiB used: 22.89 GiB (2.7%) fs: ext4
    dev: /dev/nvme0n1p4
  ID-1: swap-1 type: partition size: 5.86 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p3
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 306 Uptime: 3m Memory: 31.02 GiB used: 2.4 GiB (7.7%)
  Init: systemd v: 250 target: graphical (5) default: graphical Compilers:
  gcc: 12.2.1 Packages: pm: rpm pkgs: N/A note: see --rpm Shell: Bash
  v: 5.2.2 running-in: gnome-terminal inxi: 3.3.22

All that looks good.
It shows you actually have the nvidia driver loaded and active.

The kernel command line looks similar to mine, but I have some additional things.
What do you have with cat /etc/default/grub?
Please post it in the </> preformatted text tags so it retains the formatting as seen on screen for you. Note that I edited your post above and added those tags so your data was more readable.
My line from that file that has the data of interest is

GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 initcall_blacklist=simpledrm_platform_driver_init rhgb quiet kvm.ignore_msrs=1"

The options there that are missing from yours as seen with the dmesg output are initcall_blacklist=simpledrm_platform_driver_init and kvm.ignore_msrs=1
I don’t remember when or how those options were added but I seem to recall that it may have been nvidia related. I have that on my desktop daily driver as well as on my laptop.

1 Like

Well that at least is good. Can you share with me which line or lines show that the NVIDIA driver is loaded and active (just for my own reference and understanding)?
Thank you for formatting.

So, for /etc/default/grub:

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=UUID=e3b19f3d-64f6-4b15-8af9-dd17a9226be3 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1"

is kvm.ignore_msrs=1 for virtual machine options?

I went and checked out the inticall_blacklist option, this does seem promising. I’ll be honest though, I am confused on how to make this option stick. My last attempt was to edit /etc/grub2.cfg and then grub2-mkconfig, but it seems that it didn’t save it??? Is this how I want to add these options, or is there a more permanent/easier way?

As of today, I’m not sure if my boot options were actually changed. I thought I had changed them, but they may have changed back. If that is the case, then my computer is booting just fine and I have had no issues as of today. I did install a new kernel version today iirc.

Thanks for your help Jeff V. You are fantastic and I appreciate your time.

That from lsmod shows the nvidia drivers are loaded and active, as does the dmesg output.

To add the suggested options to the kernel command line you could do so temporarily (for that boot only) edit the grub entry from the grub menu by pressing e with the kernel being booted displayed then enter the option into the line that begins with linux

To do it permanently you could edit the /etc/default/grub file and add the option to the GRUB_CMDLINE_LINUX line, then after saving it run sudo grub2-mkconfig -o /boot/grub2/grub.cfg which will recreate the entries for the next boot and it will remain for future updates. I hope that grub2-mkconfig line is exactly what you used before.

Here are the docs for working with grub2

1 Like


Thank you for your response and continued time and support. For the time being, my computer has begun to turn on with no issues. There was one time that when booting it said “nvidia drivers rolling back to Nouveau driver,” but when I rebooted, I did the lsmod command as you stated before and it showed the same thing about nvidia drivers being on and active.

I will continue to monitor the solution, especially as we head into F37 and try out your options if I hit a point at which I’m no longer booting.

Again, having the ability to check and know is something I learned along the way.

Best regards,

1 Like