Reinstalled systemd / systemd-udev now resolve is broken

Hey so… Originally I had this issue
First issue

But now I’m much worse off! :smiley:

I attempted to run dnf --refresh reinstall systemd systemd-udev thinking it wouldn’t be too bad to try… I was very wrong apparently!

I have no networking at all now. Systemd-resolved.service will not start at all.

Failed to start systemd-resolved.service - Network Name Resolution.
systemd-resolved.service: Scheduled restart job, restart counter is at 5.
systemd-resolved.service: Start request repeated too quickly.
systemd-resolved.service: Failed with result 'exit-code'.
Failed to start systemd-resolved.service - Network Name Resolution.

there is NOTHING in my /run/systemd/resolve folder for /etc/resolv.conf to link to now.

I’m at a complete loss now.

Added f40, systemd, systemd-resolved, workstation

Do you have good backups ? Do you have a LiveUSB ?

I have a LiveUSB, but reinstalling is the last thing I want to do. It’d take days to set up a workstation and restore files.

I was going to comment that you would need to systemd-nspawn or chroot your partition, and point dnf --installroot to your partition using update or distro-sync to help you through some of this.
As a way around having to reinstall. . .

It’s very involved and will take time as you troubleshoot. The LiveUSB would at least give you networking and an environment while you work.

Uh-oh… like boot from a liveusb and use it to update my install? I’ve never done something like that before.

What would be the steps to do something like that?

Thank you for trying to help.

Unfortunately, I’m leaving the Library in 10 mins, So I cannot help much for the next hour or so.

The idead in the Live USB, would be to have an environment with networking, and utilize dnf from the LiveUSB to fix your mounted partition’s install. Pointing it from the outside to update the system. We’ve done things like this before on broken installs, but again, very time consuming.

Maybe other can chime in with other workarounds or solutions :fedora:

After a bunch of reading docs I managed to figure it out sort of.
How ever, upon running dnf --installroot='path to root' distrosync I’m getting the same error as before from my link above.

But I’m unsure how to fix the systemd and systemd-udev stuff to get networking back. :sob:

Just made it to the coffee shop so I’m back on wifi.

:muscle:t5: :sunglasses:

Could you try to reinstall the packages you are missing Instead of the update?

systemd and systemd-udev? I can try yeah, but I tried to reinstall them before and that’s what broke networking.

Edit: I tried dnf --installroot='path to root' reinstall systemd systemd-udev and no dice.

Still no networking.

So from the Live environment you would :

  • dnf --installroot=/path/to/partition clean all
  • dnf --installroot=/path/to/partition install systemd-udev 'any other package'
  • and if you need to add --allowerasing and --best

Just says it’s already installed.

The issue is there is nothing inside of /run/systemd/resolve/ any more since I tried to reinstall and I don’t know how to generate what should be in there. It’s quite odd.

1 Like

First we need to find out if the network really doesn’t work, or if it just the dns lookup that doesn’t work. For that, run the command

ip link
ip address

If that shows you got assigned an IP number, you can bypass the missing resolved program by removing the file or symbolic ling /etc/resolv.conf and creat the file /etc/resolv.conf with the content


That would be a temporary work-around while trying to analyze the resolved issue.

If you didn’t get an IP number assigned, then the problem would rather be with NetworkManager instead of systemd-resolved.