Random system shutdown, kernel 6.6.2

Just wondering if anyone else is experiencing random system shutdowns since the last update?

I’m running 39 on a Tuxedo InfinityBook Pro 16 - Gen8
Intel Core i7-13700H
Intel Iris Xe Graphics

I had the same thing running Arch, which I just blamed on Arch at the time but then I realised it was running the same kernel at the time.

It’s hard to debug because the machine just goes poof!! Complete shutdown, no chance to write logs. Memtest didn’t return anything

Please post as preformatted text (using the </> button on the toolbar) the full output of inxi -Fzxx so we may see the pertinent details of your installation. You may need to install inxi to run that command.

I have not had any unexpected shutdowns on my systems.

Here you go

System:
  Kernel: 6.6.2-201.fc39.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.40-13.fc39 Console: pty pts/1 wm: gnome-shell DM: GDM Distro: Fedora
    release 39 (Thirty Nine)
Machine:
  Type: Laptop System: TUXEDO product: TUXEDO InfinityBook Pro Gen8 (MK1)
    v: Standard serial: <filter>
  Mobo: NB02 model: PH4PRX1_PH6PRX1 v: Standard serial: <filter>
    UEFI: American Megatrends LLC. v: N.1.10A05 date: 07/20/2023
Battery:
  ID-1: BAT0 charge: 64.9 Wh (79.0%) condition: 82.1/82.1 Wh (100.0%)
    volts: 16.2 min: 15.5 model: standard serial: <filter> status: discharging
CPU:
  Info: 14-core (6-mt/8-st) model: 13th Gen Intel Core i7-13700H bits: 64
    type: MST AMCP arch: Raptor Lake rev: 2 cache: L1: 1.2 MiB L2: 11.5 MiB
    L3: 24 MiB
  Speed (MHz): avg: 673 high: 1136 min/max: 400/4800:5000:3700 cores: 1: 747
    2: 400 3: 775 4: 400 5: 807 6: 490 7: 747 8: 400 9: 638 10: 1121 11: 943
    12: 400 13: 987 14: 400 15: 883 16: 1136 17: 400 18: 400 19: 400 20: 999
    bogomips: 116736
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: Tongfang Hongkong
    driver: i915 v: kernel arch: Gen-13 ports: active: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 0000:00:02.0 chip-ID: 8086:a7a0
  Device-2: [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
    bus-ID: 3-6:3 chip-ID: 2b7e:c757
  Display: server: X.Org v: 23.2.2 with: Xwayland v: 23.2.2
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96
  Monitor-1: eDP-1 model: BOE Display 0x0a3b res: 1920x1200 dpi: 143
    diag: 406mm (16")
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.2.1 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel Graphics (RPL-P)
    device-ID: 8086:a7a0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Raptor Lake-P/U/H cAVS vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel bus-ID: 0000:00:1f.3 chip-ID: 8086:51ca
  API: ALSA v: k6.6.2-201.fc39.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.0 status: n/a (root, process) with:
    1: pipewire-pulse status: active 2: wireplumber status: active
    3: pipewire-alsa type: plugin
Network:
  Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f1
  IF: wlo1 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 3-10:4 chip-ID: 8087:0026
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.2
    lmp-v: 11
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
    driver: vmd v: 0.6 bus-ID: 0000:00:0e.0 chip-ID: 8086:a77f
Drives:
  Local Storage: total: 1.82 TiB used: 36.08 GiB (1.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 28.9 C
  ID-2: /dev/nvme1n1 vendor: Corsair model: MP600 CORE XT size: 931.51 GiB
    speed: 63.2 Gb/s lanes: 4 serial: <filter> temp: 25.9 C
Partition:
  ID-1: / size: 929.53 GiB used: 35.74 GiB (3.8%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 305.3 MiB (31.4%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 998 MiB used: 44.1 MiB (4.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 929.53 GiB used: 35.74 GiB (3.8%) fs: btrfs
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 29.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Processes: 446 Uptime: 3h 6m Memory: total: 16 GiB available: 15.36 GiB
  used: 4.16 GiB (27.1%) igpu: 60 MiB Init: systemd v: 254
  target: graphical (5) default: graphical Compilers: N/A Packages: pm: rpm
  pkgs: N/A note: see --rpm pm: flatpak pkgs: 16 Shell: Sudo v: 1.9.14p3
  running-in: gnome-terminal inxi: 3.3.31

Random crashes are often due to heat or power issues. Do you use the TUXEDO Control Center?
TUXEDO Control Center Issue 149 mentions a COPR repo and indicates that the rpm packages should support both SUSE and Fedora.

Laptops are prone to overheating due to accumulated dust on fans and cooling fins. “Canned Air” is used to clean them, but generally requires some disassembly.

It is worth contacting TUXEDO Support – if the issue affects other users they may already know about it and have a solution.

It crossed my mind but the laptop was under very low load, so cool at the time with a full battery.
The machine is only 2 months old.

The reason why I asked here was to see if it could be kernel-related, but if it happens again I will contact Tuxedo.

Thanks!

An instant shutdown (really instant, i.e. not a shutdown during which you can see some shutdown messages, a shutdown screen, etc) is in 99% cases hardware-related. Run memtest over night, and then prime95 over (another) night, whether they report errors.

I’ll start running the tests tonight.

The memtest revealed no issues.

I did receive immediate support from Tuxedo and they advised me to enable the GuC functionality, by adding grub param i915.enable_guc=2

No crashes so far.
Hopefully it stays like that.