Quadro K1000M driver issue on F40 sway

Hi everyone,

I’m having some issues getting Nvidia driver (so far tested 470xx and 390xx) working properly on a Thinkpad W530 equipped with Nvidia Quadro K1000M.

The machine has no issues running with the noveau driver, but when I try installing any of the Nvidia drivers, does not output anything to the display after initial Fedora loading screen.

Rpm fusion repos are enabled, and installation of the drivers themselves work without any error messages.

I’m running Fedora 40 sway spin - some output below:

/sbin/lspci | grep -e VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1000M] (rev a1)

uname -r

Here’s the command I used to install the 470xx driver (which seems to be the recommended driver version for this particular legacy card).

sudo dnf install xorg-x11-drv-nvidia-470xx akmod-nvidia-470xx

What should my next step be? I’d be happy to provide more info if it could help.

Thank you!

Is secure boot enabled? mokutil --sb-state will show that.
Are you using wayland or xorg? the nvidia 470 driver does not support wayland.
Please show us the output of dnf list installed \*nvidia\*

1 Like

@computersavvy I haven’t used Sway but I did use i3wm a while ago, so there is no X11 on Sway? Do you know?

Added sway, wm

I have not used Sway so don’t know if it has X11 or not. Without X11 the nvidia drivers (470 version and older) are useless.


My assumption is that Sway is the Wayland version of i3WM :thinking: , hope the OP get’s back to us here.

Thank you for responding!

mokutil --sb-state
SecureBoot disabled

It looks like secureboot is disabled.

I believe I’m on wayland - sway is the wayland superset of x11 based i3 (if my very newbiesh search is correct). Checking it through below command seems to confirm that.

loginctl show-session 2 -p Type

Right now I’m running on nouveau. I had the blackscreen issue (alt-f2 still worked, however) so deleted the nvidia driver install through

dnf erase *nvidia*

Which reverted the system to a normal, graphics-outputting state. Running the dnf list installed command returns no packages (probably because I deleted them already).

Oh - so am I just facing off against limitations of older hardware?

If so, would you have a suggestion on what I might be able to do here? Maybe find an x11 based distro and sticking on this machine with 470/390 driver install… Or is there a somewhat new user friendly way to switch F40 to x11?

This was an error in that it would also remove the nvidia-gpu-firmware package which is required for many nvidia GPUs. That package should be reinstalled.

It would appear that you are facing the issue of older nvidia GPUs that require the 470 or older driver are not capable of working with wayland.
Thus if you wish to use the nvidia driver instead of nouveau you would need to either enable X11 in Sway (I cannot help with that) or switch to a spin that still has X11.

I believe i3WM is similar to Sway but has X11 (as noted by @hamrheadcorvette above), and most of the spins still do support X11 for now. You would have to decide which meets your needs then switch to that spin so X11 is available on the desktop.

1 Like

Yes, in retrospect combination of wayland-only sway and very old gpu was just asking for trouble.

I’ll try out the xfce spin as a safer choice. Thank you for the assistance!