PS4 controller shows up as Xbox

My DualShock 4 is apparently being correctly recognized:

$ lsusb | grep Sony
Bus 001 Device 012: ID 054c:05c4 Sony Corp. DualShock 4 [CUH-ZCT1x]

but since about three weeks, I’ve noticed that in all games I’ve tried, the controller is seen as an Xbox controller, I’m playing games through Flatpak apps such as Steam and Heroic Games Launcher if that matters, I had the same setup before and it was working correctly, so I was wondering what changed, if it was due to a system update or an issue on my end.

I also tried using ds4drv, but it didn’t make a difference.

Which games?

Every game, but examples that also show the button icons are Brawlhalla, Multiversus (Steam), Dandara, Sonic Mania (Heroic).
Now I also checked SuperTuxKart, both Flatpak and RPM list the Xbox buttons, though the name of the input device is correct

This may not have anything to do with Flatpak after all, any ideas?

Have you tried removing the flatpak version of steam and installing it from the rpmfusion repo as the rpm version? For me it works that way, though I do not use a PS4 controller.

I can try, why should I uninstall the Flatpak Steam though, can’t they be run separately?

I tried that and I get the same result, if it was something I did to my system where should I start looking into?

SuperTuxKart does that for me as well with a DualSense.

Does Steam itself show the correct controller mapping? Did you enable PlayStation Configuration Support?

Before buying this controller, I recall reading that this is dependent on games. Steam will map the controller to the input method they support, but it will still appear as an XBox controller to them (and they probably only have UI that matches it too.) Unfortunately, I can’t seem to find the articles saying that again.

No I didn’t enable that, when I checked, the controller wasn’t even detected.

Is it? Because I had it working correctly in every game before, with no tweaks.
Now I have an even weirder problem though

Everything fixed by itself, so I don’t know what changed at all, is there a way to check?
Maybe the history of package upgrades of dnf, to your knowledge, is there a package/packages I should look at in particular? Or could it be something else entirely?

Responding to myself here, one of my recent transactions (dnf history info 203) had

Install steam-devices-                  @rpmfusion-nonfree-updates

from when I reinstalled the RPM Steam like suggested by @computersavvy
I think this might very well be the thing that changed, correct?

Very possibly.

That package was not previously installed and it is known that fedora & rpmfusion try to keep up with all needed changes. The flatpak creator may often not do so, or be delayed in doing updates.

Oh I see. Looking for more info I found this on the repository for the Steam Flatpak

So yeah, the solution was right in front of me since the beginning :sweat_smile:
Just out of curiosity, could a Flatpak set those udev rules or is it a technical limitation?