Prohibited Client Endianness message while using X11 applications from Fedora 38 to Oracle SPARC Solaris 11.x

I need detailed steps about how to implement solution provided in the following URL:

https://fedoraproject.org/wiki/Changes/XServerProhibitsByteSwappedClients

Thank you

For me, it is a blocker, not to have X11 applications running on Fedora 38. i tried the solution like adding a file including the snippet in /etc/X11/x.org.d and in /use/share/X11, but it didn’t work. I also tried the ‘gsettings’ command, but it didn’t work either.

I always relied on Fedora running X applications like Oracle runInstaller, and i don’t want to give up Fedora because of that, so detailed steps are highly appreciated on how to implement the solution.

Thank you.

Hello,

This is exactly what is happening when I try to run an X11 program on Fedora 38

$ssh -X to the database server

After successful login:

$ owm
Prohibited client endianess, see the Xserver man page Exiting
java.lang.NullPointerException
at oracle.ewt.lwAWT.BufferedApplet.(Unknown Source)
at oracle.sysman.emSDK.client.appContainer.WebApplication.(WebApplication.java:752)
at oracle.security.admin.wltmgr.owma.OwmaApp.(Unknown Source)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
at java.lang.Class.newInstance0(Class.java:357)
at java.lang.Class.newInstance(Class.java:310)
at oracle.sysman.emSDK.client.appContainer.WebApplication.main(WebApplication.java:3316)
Done.

For Wayland, I tried the below command on Fedora 38, rebooted it, but it did not work:

sudo gsettings set org.gnome.mutter.wayland xwayland-allow-byte-swapped-clients true

Regards.

Don’t use sudo. It’s a dconf setting for your account, not root’s.

$ gsettings set org.gnome.mutter.wayland xwayland-allow-byte-swapped-clients true

1 Like

With Wayland, I tried the same command without sudo, rebooted Fedora, but it did not work.

This is just to ask how to escalate this issue.

It is important to know how to solve this issue because I don’t want to ditch Fedora for that.

It should be a file in /etc/X11/xorg.conf.d/, with a filename ending in .conf, containing:

Section "ServerFlags"
   Option "AllowByteSwappedClients" "on"
EndSection

Note the key is AllowByteSwappedClients according to upstream and the Fedora patch, not AllowSwappedClients as written on the wiki (I’ll update it if you confirm it works).

If it still doesn’t work then file a bug against xorg-x11-server component.

Hello,

With GNOME X, it worked successfully. Thank you very much.

With Wayland, I ran “gsettings set org.gnome.mutter.wayland xwayland-allow-byte-swapped-clients true”, rebooted, but it did not work.

Regards,
Pierre

1 Like

I’ve fixed the wiki.

Not sure about Wayland, but you would file a bug against mutter in that case.

I will open a ticket with mutter.

Thank you very much.