Problem with FCOS create partition and disk

Hello, I’m testing FCOS and it turns out that when I try to create disks and partitions by ignition the installation occurs normally, but when starting the system it ends up getting stuck in the “Startup finished” part and the login screen does not appear.

I am installing a disk with .iso bare-metal on a vmware and also tested it on a citrix hypervisor with the following command “sudo coreos-installer install /dev/sda --ignition-url http://192.168.0.71/fcos.ign --insecure-ignition ”.

It is interesting that when I install with an ignition without creating the partitions the login screen appears normally and when I use an ignition creating the partitions the login does not appear, however using a fdisk with .iso live the partitions are created.

This the login shows: https://pastebin.com/YVuzLCpA
This the login dont shows: https://pastebin.com/Ltb3c8Ea

Thanks a lot!

In the second FCC, you have size_mib: 0 which is probably not what you want.
Edit: This is not true (I had forgotten about the special case for 0). Sorry for the noise.

You don’t need to provide a mount unit if you use with_mount_unit: true.

The following is also probably not needed:

directories:
  - path: /var/dados
    overwrite: true

In your filesystems section, you’re using device: /dev/sdb, but I think you meant device: /dev/sdb1.

Thanks Siosm and jlebon, these tips solved my problem!

Great! Can you mark it as solved? Thanks!