Problem: UTF8 not working anymore?


sudo localectl set-locale LANG=de_DE.UTF-8

I have no Idea what caused this…

I have a really weird bug, UTF-8 doesnt work anymore!

This breaks a lot of apps, as I am german and some paths are with Umlauts.


[user@fedora user]$ Ö
bash: $'�\226': Kommando nicht gefunden.

Some names are renamed with the �.

Cryptomator doesnt work anymore, I guess because of renamed paths. Symbols are missing there too, I have the feeling this has the same reason.

qBittorrent cant find a folder that I can open in Dolphin RPM.

I am on Kinoite, so all these apps are Flatpaks, maybe that is the case?

What output you get typing localectl in terminal?
(please paste it here as preformated </> text)

If the locale variables does not include the “.utf8” suffix you get this problem. Note: LC_ALL overrides all the other locale variables.

[vek@newbox ~]$ export LC_ALL=de_DE
[vek@newbox ~]$ Ö
bash: $'�\226': Kommando nicht gefunden.
[vek@newbox ~]$export LC_ALL=de_DE.utf8
[vek@newbox ~]$ Ö
bash: Ö: Kommando nicht gefunden.
[vek@newbox ~]$ 

[user@fedora user]$ localectl
System Locale: LANG=de_DE.UTF-8
VC Keymap: de-nodeadkeys
X11 Layout: de
X11 Variant: nodeadkeys

@vekruse thank you very much! I have no idea how this happened, its a new bug for like 3 days.

I will see if that also fixes folders and Flatpak behavior.

export LC_ALL=de_DE.utf8

ok for some reason this didnt fix the Cryptomator bug with only boxes showing instead of letters…

I think entering that export command will only affect that terminal and things “spawned” from it. You’ll probably have to find where Cryptomator is picking its settings up from. You might check the /etc/locale.conf and /etc/environment files. Unfortunately, there are a lot of places where that variable might be incorrectly set. Places like the systemd service file that starts the application and your ~/.bash{_profile,rc} files are also possibilities. I think if you use the locale command, you might be able to see a more complete listing of the various LANG variables.

1 Like

No need to qualify this with “I think”. It is a fact and there is no doubt about it.

Another clue could be to run

sudo find /etc -mtime -4 -exec ls -dl {} +

to find files in the /etc directory which are newe than 4 days. That would be the prime suspects.

Did you change fonts to try to fix before? If yes put them back as they where.

My experiences with computers have left me doubting that 2 + 2 = 4. :stuck_out_tongue:

@ilikelinux I didnt change fonts at all I think? But I see fonts appearing, weird. The standard fonts I use are the same. but see the output below maybe

@vekruse Ok I printed that to a file, anything I should look for? I searched for “code”:

interesting finds:

-rw-r--r--. 1 root    root        269 12. Feb 21:03 /etc/anthy-unicode.conf
lrwxrwxrwx. 1 root    root         62 12. Feb 21:03 /etc/fonts/conf.d/61-adobe-source-code-pro.conf -> /usr/share/fontconfig/conf.avail/61-adobe-source-code-pro.conf
-rw-r--r--. 1 root root       86 12. Feb 21:03 /etc/xdg/

I got more errors, here is a LUKS dialog requesting the sudo password (working normally)

Please create a new user and check if you have the same problem. So we know if it is a local config error or a system wide.

You should be looking for “LC_”. At the time the problem started, something must have been changed. Usually that would be a file somewhere in /etc that has been created or modified recently.

What is the output of the locale command?

I can imagine that the above file interferes with the default config /etc/user-dir.conf:

# This controls the behaviour of xdg-user-dirs-update which is run on user login
# You can also have per-user config in ~/.config/user-dirs.conf, or specify
# the XDG_CONFIG_HOME and/or XDG_CONFIG_DIRS to override this


# This sets the filename encoding to use. You can specify an explicit
# encoding, or "locale" which means the encoding of the users locale
# will be used

solution found:

sudo localectl set-locale LANG=de_DE.UTF-8
1 Like