Locale broken after system-upgrade


After the system-upgrade to Fedora 38, my locale broke. It should be de/german, but it’s en_us/us. I tried using localectl to set the locale, but it breaks again after every reboot. How can I fix this?


Can you please give us the output of localectl
And the command you tried to change it.

This is after I have changed the keyboard layout in the KDE settings, before running any of the commands I tried:

System Locale: LANG=de_DE.UTF-8
    VC Keymap: de
   X11 Layout: us

The commands I tried were:
sudo localectl set-keymap de,
sudo localectl set-x11-keymap de,
sudo localectl set-keymap de --no-convert
sudo localectl set-x11-keymap de --no-convert.

Do I understand right, you want everything in de ?

Yes, exactly.

Give this a try:

1 Like

Doesn’t work.

In deutsch:

It’s still only temporary. On each reboot, it changes back to US.