Problem installing MariaDB

I’m trying to install MariaDb, and it seems to install okay, but then systemctl can’t find it. No idea what my next step is to fix and I can’t find any other answers online.

louis@FV-NewPC:~$ sudo dnf install mariadb
Last metadata expiration check: 2:20:46 ago on Sun 07 Jul 2024 12:43:52 PM EDT.
Package mariadb-3:10.11.8-3.fc40.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
louis@FV-NewPC:~$ sudo systemctl enable mariadb
Failed to enable unit: Unit file mariadb.service does not exist.
louis@FV-NewPC:~$ sudo systemctl start mariadb
Failed to start mariadb.service: Unit mariadb.service not found.

Perhaps you mean to install mariadb-server?

$ rpm -ql mariadb-server | grep '/mariadb.service$'

Is that not what I installed?? The package description says it’s the server. Shouldn’t I prefer dnf over rpm?

louis@FV-NewPC:~$ sudo dnf info mariadb
Last metadata expiration check: 2:20:24 ago on Sun 07 Jul 2024 12:43:52 PM EDT.
Installed Packages
Name         : mariadb
Epoch        : 3
Version      : 10.11.8
Release      : 3.fc40
Architecture : x86_64
Size         : 22 M
Source       : mariadb10.11-10.11.8-3.fc40.src.rpm
Repository   : @System
From repo    : updates
Summary      : A very fast and robust SQL database server
URL          :
License      : GPLv2 and LGPLv2
Description  : MariaDB is a community developed fork from MySQL - a multi-user,
             : multi-threaded SQL database server. It is a client/server
             : implementation consisting of a server daemon (mariadbd) and many
             : different client programs and libraries. The base package
             : contains the standard MariaDB/MySQL client programs and
             : utilities.

It looks like you found a bug. That summary should state that the mariadb package is just the clients. You can report this problem at if you want to try to let the devs know about it.

Yes. I just used the rpm command because it has a convenient option to list all the files in an installed package.

Yep, that did the trick. Thanks!

Added f40, mariadb