Mariadb Installation Problem

I need to install MariaDB and then LAMP but it seems i have a problem here. So i follow the official Fedora Wiki instructions, according to that, first i need to install mariadb and mariadb server. When i run dnf install mariadb mariadb-server the return is: Package mysql-community-client-8.0.17-1.fc30.x86_64 is already installed. Package mysql-community-server-8.0.17-1.fc30.x86_64 is already installed. Dependencies resolved. Nothing to do. Complete!

So i already installed MariaDB, it seems, but when i run systemctl start mariadb the return is: Failed to start mariadb.service: Unit mariadb.service not found.

What’s the actual problem here?

1 Like

Sorry I can’t be more precise right now, but as far as I know, mariadb and mysql are two different products.

1 Like

You’re right, i did separate installations for both. Suppose, everything is fine with mySQL -and also Apache- but i can’t figure out what’s the problem with mariadb.

MariaDB conflicts with MySQL, so you can’t install both.
You should either use MySQL, or disable its repository and replace it with MariaDB.

1 Like

Or start MySQL service instead of mariadb one :slight_smile: