Problem doing a shortcut for spotify

Hi, i’m a newcomer fedora’s user. I want to do a shortcut to open spotify, but i have some problems trying to do it:
First, i install spotify via flatpak and pass this command to shortcut: ‘flatpak run com.spotify.Client’. If i do so, the shortcut opens the config app of gnome.
Second, i try to install via snap and pass this command to shortcut: ‘spotify’. The same thing happens via flatpak shortcut.
Both commands run perfectly via terminal.
I don’t know what to do. Can you folks help me? Thanks

Welcome @whantrus

Yes, we all have been there once. And it is true Linux works a bit different as common OS’ es

Ok, i made it too right now. After install you click on >> Activities > type spot > and the Icon should apear, right?
Right click on the Icon > Pin to dash, and that’s it :thinking:

I do use the extension “Dash to dock” to keep my shortcuts always visible, alias make them visible moving the Mouse to the place the dock is.

I do not see why you should be “doing a shortcut” in the first place? The installation of the flatpak version of Spotify automatically installs a valid desktop launcher. There should be no need for intervention from your part.

Perhaps you need to be more specific of what exactly you are trying to achieve and what you tried, in particular, how are you proceeding to “do” the shortcut.

Just for the record, users coming from Gnome2 based desktops as Mate, Cinnamon etc. have been used to use their desktop as they could use also with Windows.

This users are also not used to to click on “Activities” while they have to type the app name they looking for.

For me it is a bit more than a year I made peace with gnome >3 / 4. Since then I not use so often to ask, why is something there where it is. It is more a “where is it” and “how to” to achieve the task I like to solve.

The question is legit … It is not a year I made a similar question.

1 Like

Hey guys.
I came from Linux Mint Cinnamon. I know that Wayland is more secure than X11, but I feel that I can do so much more tweaks in X11. Still in the process of getting in flow with Wayland… yesterday I was able to fix an old script for Nautilus that won’t work anymore in gnome 40. So proud of it :grinning:

Just because I want it. I like to give keyboard shortcuts to programs that I use often.

Back to the problem: I wasn’t able to change the Fn+F5 shortcut. Perhaps it’s a gnome shortcut that is overlapping what I try to do. I solve the problem pointing to another shortcut.

Fn is used to switch between two functions of a key. You just can use keys who offer two functions with it. I tested it with the Fn key and the PgUp/Menu on my keyboard. This works.

Gnome is so smart to tell you if this is the case. You will se an exclamation mark and a message above the shortcut.

For flatpaks you can use the below for keyboard shortcuts:
system install → /var/lib/flatpak/exports/bin/name.of.flatpak
user install → ~/.local/share/flatpak/exports/bin/name.of.flatpak

Another alternative you could do on gnome is pin them to the dash, and then launch them with Super 1,2,3 etc … In the order they are pinned.



I understood you wanted to make a launcher icon (“shortcuts” in Windows), but the thread and your comment makes clear you refer to a keyboard shortcut. My issue was that, to me, your question was not clear. A launcher icon is automatically installed. A keyboard shortcut can be made in Settings - Keyboard - Custom Shortcuts. The flatpak run com.spotify.Client works for me if I assign it to a shortcut key.

Sorry for not make it clear. For some reason, the Fn+F5 shortcut (I used that key in Cinnamon to open spotify) is locked to another built-in function. I tested with other commands and doesnt work as well.

That could be bound to a media key. You can see these in dconf-editor /org/gnome/settings-daemon/plugins/media-keys/, then disable an assignment by setting the value to '' so you can use the key for a custom shortcut. If the effect is undesired, the key can easily be reset to default in dconf-editor. But I see this is solved for you already.