Printer Configuration Problem

Using Fedora 39 KDE on a Lenovo R400 laptop, which has USB and Firewire ports but neither RS232 or parallel ports. The laptop communicates with the network wifi router and to various printers but, going through obsolete equipment I decided to see if I could establish a parallel cable connection to one of the older printers.

My target printer is a Canon BJC-80 and I have two paths for cabling: an USB-to-parallel cable witrh a Centronics connector and a PCMCIA card with a D-sub 25 connector. Using the USB connector the OS identifies the cable in lsusb (Qin Heng Electronic CH340S) and when I attach it to the BJC printer the OS adds the printer to the system automatically, selecting a BJC-80 driver and CUPS 5.4.

Attempts to print to the printer reveal a problem however: There is evidence (progress bars, blinking lights) of communication but the output is largely lost except for a few stray characters not related to content.

I then thought maybe I could communicate with the printer using DOS, as I had done successfully in the past, but another problem arose: How to get DOS on a Linux machine, specifically, one that could communicate with the printer? I tried WINE, whos support for DOS has been deprecated. I tried DOSBox Staging, which apparently does not support printing - at least as far as I could find. I tried DOSBox-X but it seemed buggy and I could not configure it successfully.

I read that some have installed a VM and then DOS on the VM, but I have no idea if the DOS instance will be able to figure out what Linux is calling a parallel port. So I’m writing asking for suggestions: Has anyone else found a solution to this problem?

Thanks for your suggestions
-CH-

If the printer is only able to connect using a parallel port then I have a couple suggestions.

Bite the bullet and spend the $ to get a newer and better supported printer. Almost 100% of printers made since 2000 have usb or wifi connections available.

Alternatively get a print server that does have the parallel port connections (they are still available) and use it to actually operate the printer. I used one in that manner back in the '90s when parallel ports were being phased out on PCs. These are examples with a quick search. There were many results
https://www.amazon.com/X-MEDIA-Ethernet-Parallel-100Mbps-XM-PS110P/dp/B07RHWB9FL/ref=pd_lpo_sccl_1/139-3111942-7779460?pd_rd_w=CliPz&content-id=amzn1.sym.1ad2066f-97d2-4731-9356-36b3edf1ae04&pf_rd_p=1ad2066f-97d2-4731-9356-36b3edf1ae04&pf_rd_r=51EYDB6T6EFQM06NAB61&pd_rd_wg=Z8dsk&pd_rd_r=2b20d183-7866-45e4-bfcf-b67373c30fa8&pd_rd_i=B07RHWB9FL&psc=1

https://www.amazon.com/Hawking-HWPS12UG-Wireless-Print-Server/dp/B0001R03X6/ref=sr_1_5?crid=3C16900KQ9YYU&keywords=wireless+print+server+for+parallel+printer&qid=1706975139&sprefix=wireless+print+server+for+parallel+printer%2Caps%2C98&sr=8-5&ufe=app_do%3Aamzn1.fos.f5122f16-c3e8-4386-bf32-63e904010ad0

A Canon BJC-85 with an USB port solved the problem: Fedora 39 KDE recognized and installed the printer.